1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/python-distutils.mk
DEB_PYTHON_INSTALL_ARGS_ALL += --single-version-externally-managed \
--install-layout=deb
DEB_PYTHON_BUILDDIR := $(CURDIR)/$(DEB_BUILDDIR)/build
binary-post-install/python-cheetah::
sed -i 's
$(cdbs_python_destdir)usr/bin/*
for buildver in $(cdbs_python_flavors:python%=%); do \
echo "Running tests with python$$buildver..." && \
cd $(DEB_SRCDIR) && \
PATH=$(DEB_PYTHON_BUILDDIR)/scripts-$${buildver}:$$PATH \
PYTHONPATH=$$(echo $(DEB_PYTHON_BUILDDIR)/lib.linux-*-$$buildver) \
python$$buildver $(DEB_SRCDIR)/cheetah/Tests/Test.py || \
echo "FAILED with python$$buildver"; \
done
|