1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51
|
export PYBUILD_NAME=cherrypy3
include /usr/share/dpkg/default.mk
include /usr/share/dpkg/pkg-info.mk
export SETUPTOOLS_SCM_PRETEND_VERSION = $(DEB_VERSION_UPSTREAM)
%:
dh $@ --buildsystem pybuild --with python2,python3,sphinxdoc
override_dh_auto_test:
-PYBUILD_TEST_ARGS="cherrypy/test cherrypy/wsgiserver -l " dh_auto_test
override_dh_auto_build:
cp -a man/cherryd.1 debian/cherryd.1
cp -a man/cherryd.1 debian/cherryd3.1
dh_auto_build
override_dh_install:
find debian/python*-cherrypy3/ -name LICENSE.md -exec rm {} \;
dh_install
mv debian/python3-cherrypy3/usr/bin/cherryd debian/python3-cherrypy3/usr/bin/cherryd3
rm -r debian/python*-cherrypy3/usr/lib/python*/dist-packages/cherrypy/tutorial
rm -r debian/python*-cherrypy3/usr/lib/python*/dist-packages/cherrypy/test
override_dh_compress:
dh_compress -X.py -X.pdf
override_dh_sphinxdoc:
ifeq (,$(findstring nodocs, $(DEB_BUILD_OPTIONS)))
http_proxy='http://127.0.0.1:9/' PYTHONPATH=. /usr/share/sphinx/scripts/python3/sphinx-build -N -q -E -b html docs/ debian/python-cherrypy3-doc/usr/share/doc/python-cherrypy3-doc/html/
dh_sphinxdoc
endif
|