1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39
|
From: Richard Lewis <richard.lewis.debian@googlemail.com>
Date: Thu, 17 Oct 2024 22:27:04 +0100
Subject: chkrootkit: rexedcs
Forwarded: yes
(Forwarded by email: 21 Dec 2024)
chkrootkit | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/chkrootkit b/chkrootkit
index 14a66af..d84fd56 100755
@@ -2335,11 +2335,11 @@ chk_tar () {
rexedcs () {
STATUS=${NOT_INFECTED}
- CMD=`loc in.rexedcs in.rexedcs $pth`
+ CMD=$(loc in.rexedcs in.rexedcs "$pth")
if [ "${?}" -ne 0 ]
- then
+ then
if [ "${QUIET}" != "t" ]; then echo "not found"; fi
- return ${NOT_FOUND}
+ return "${NOT_FOUND}"
fi
if [ "${EXPERT}" = "t" ]; then
@@ -2347,7 +2347,8 @@ rexedcs () {
return 5
fi
STATUS=${INFECTED}
- return ${STATUS}
+ echo "INFECTED: $CMD"
+ return "${STATUS}"
}
chk_mail () {
|