1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115
|
DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
INSTDIR=$(CURDIR)/debian/chktex
CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
TMPCFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
DEBDATE:=\\\date{$(shell TZ=UTC LC_ALL=C date -d "$$(dpkg-parsechangelog -SDate)" +'%m\/%d\/%Y')}
CFLAGS = -Wall -fstack-protector --param=ssp-buffer-size=4 -Wformat $(CPPFLAGS)
INSTALL = install
INSTALL_FILE = $(INSTALL) -p -o root -g root -m 644
INSTALL_PROGRAM = $(INSTALL) -p -o root -g root -m 755
INSTALL_SCRIPT = $(INSTALL) -p -o root -g root -m 755
INSTALL_DIR = $(INSTALL) -p -d -o root -g root -m 755
#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
# CFLAGS += -O0
#else
# CFLAGS += -O2
#endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
config config.status: configure
dh_testdir
# Add here commands to configure the package.
echo $(LDFLAGS)
./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) \
--prefix=/usr --mandir=\$${prefix}/share/man --sysconfdir=/etc
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp: config.status
dh_testdir
# Add here commands to compile the package.
# build source
cp -p ChkTeX.tex.in ChkTeX.tex.in.backup
echo $(DEBDATE)
echo $(LIBS)
sed -ri "s/.date..today./$(DEBDATE)/g" ChkTeX.tex.in
$(MAKE) CFLAGS="$(CFLAGS) $(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" LIBS="$(LIBS) -lpcreposix -lpcre -ltermcap" chktex ChkTeX.dvi
# build html documentation
$(MAKE) html
mv ChkTeX.tex.in.backup ChkTeX.tex.in
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
# Add here commands to clean up after the build process.
[ ! -f Makefile ] || [ ! -f config.status ] || $(MAKE) clean
-rm -f ChkTeX.dvi ChkTeX.tex ChkTeX.readme config.status stamp-h
-rm -f config.h Makefile Readme.header
-rm -f deweb rmeheader
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
# Add here commands to install the package into debian/chktex.
$(MAKE) install DESTDIR=$(INSTDIR)
mkdir -p $(INSTDIR)/usr/share/doc/chktex/html/
cp $(CURDIR)/HTML/ChkTeX/*.html $(CURDIR)/HTML/ChkTeX/*.css $(INSTDIR)/usr/share/doc/chktex/html/
cp chktex.1 chkweb.1 $(INSTDIR)/usr/share/man/man1/
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs
dh_installman
dh_installchangelogs NEWS
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|