1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98
|
author: Andres Salomon <dilinger@debian.org>
description: include debian node libs (needed for rollup)
This is strictly just needed for bullseye's rollup , but may be useful
later on when we drop more nodejs stuff.
@@ -4,10 +4,13 @@
# found in the LICENSE file.
from os import path as os_path
+import os
NODE_MODULES = os_path.join(os_path.dirname(__file__), 'node_modules')
+os.environ['NODE_PATH'] = '/usr/share/nodejs'
+
def _path_in_node_modules(*args):
return os_path.join(NODE_MODULES, *args)
@@ -22,7 +25,7 @@ def PathToHtmlMinifier():
def PathToRollup():
- return _path_in_node_modules('@rollup', 'wasm-node', 'dist', 'bin', 'rollup')
+ return _path_in_node_modules('rollup', 'dist', 'bin', 'rollup')
def PathToSvgo():
@@ -102,8 +102,7 @@ def license_checker_path():
def rollup_path():
return path.join(
node_modules_path(),
- '@rollup',
- 'wasm-node',
+ 'rollup3',
'dist',
'bin',
'rollup',
@@ -67,7 +67,7 @@ template("bundle") {
}
} else {
node_action(target_name) {
- script = "node_modules/@rollup/wasm-node/dist/bin/rollup"
+ script = "node_modules/rollup3/dist/bin/rollup"
forward_variables_from(invoker,
[
@@ -38,7 +38,7 @@ action("build_inspector_overlay") {
"$target_gen_dir/main.js",
devtools_location_prepend + "inspector_overlay/loadCSS.rollup.js",
devtools_location_prepend +
- "node_modules/@rollup/wasm-node/dist/bin/rollup",
+ "node_modules/rollup3/dist/bin/rollup",
]
outputs = [ "$resources_out_dir/main.js" ]
@@ -28,7 +28,7 @@ node_action("generate_css_vars") {
}
node_action("optimize_images") {
- script = "node_modules/@rollup/wasm-node/dist/bin/rollup"
+ script = "node_modules/rollup3/dist/bin/rollup"
_bundled_entrypoint = target_gen_dir + "/Images.prebundle.js"
_output_file_location = target_gen_dir + "/Images.js"
@@ -24,7 +24,7 @@ devtools_module("web-vitals-injected") {
}
node_action("bundled_library") {
- script = "node_modules/@rollup/wasm-node/dist/bin/rollup"
+ script = "node_modules/rollup3/dist/bin/rollup"
_bundled_entrypoint = target_gen_dir + "/web-vitals-injected.js"
_output_file_location = target_gen_dir + "/web-vitals-injected.generated.js"
@@ -55,7 +55,7 @@ devtools_entrypoint("bundle") {
}
node_action("bundled_library") {
- script = "node_modules/@rollup/wasm-node/dist/bin/rollup"
+ script = "node_modules/rollup3/dist/bin/rollup"
_bundled_entrypoint = target_gen_dir + "/injected.js"
_output_file_location = target_gen_dir + "/injected.generated.js"
|