File: driver-requirements.txt

package info (click to toggle)
cinder 2:15.0.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 34,640 kB
  • sloc: python: 380,978; pascal: 2,186; sh: 574; makefile: 108; xml: 26; sql: 5
file content (44 lines) | stat: -rw-r--r-- 751 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
# Document dependencies that are only used if using
# certain drivers.  This file is not managed by
# requirements tools.

# HPE 3PAR
python-3parclient>=4.1.0 # Apache-2.0

# Kaminario
krest>=1.3.0 # Apache-2.0

# Pure Storage
purestorage>=1.6.0 # BSD

# Dell EMC VMAX, IBM DS8K
pyOpenSSL>=1.0.0 # Apache-2.0

# HPE Lefthand
python-lefthandclient>=2.0.0 # Apache-2.0

# Fujitsu Eternus DX
pywbem>=0.7.0 # LGPLv2.1+

# IBM XIV
pyxcli>=1.1.5 # Apache-2.0

# LINSTOR
protobuf>=3.6.1 # BSD

# RBD
rados # LGPLv2.1
rbd # LGPLv2.1

# Dell EMC VNX and Unity
storops>=1.1.0 # Apache-2.0

# INFINIDAT
infinisdk # BSD-3
capacity # BSD
infi.dtypes.wwn # PSF
infi.dtypes.iqn # PSF

# Storpool
storpool>=4.0.0 # Apache-2.0
storpool.spopenstack>=2.2.1 # Apache-2.0