1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55
|
export DEB_LDFLAGS_MAINT_APPEND=-Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export NOCONFIGURE=yes
ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
DH_PARALLEL_OPTION=--parallel
endif
%:
dh $@ --with autoreconf,python2,gir $(DH_PARALLEL_OPTION)
override_dh_autoreconf:
dh_autoreconf --as-needed ./autogen.sh
override_dh_auto_configure:
dh_auto_configure -- --enable-compile-warnings=no \
--disable-schemas-install \
--disable-silent-rules \
BROWSER_PLUGIN_DIR=/usr/lib/mozilla/plugins
override_dh_auto_test:
:
TH_DIR=debian/cinnamon-common/usr/share/cinnamon/thumbnails/metacity-1
override_dh_install-indep:
dh_install --list-missing
mv $(TH_DIR)/Adwaita.png $(TH_DIR)/Default.png
rm -f debian/cinnamon-common/usr/share/cinnamon/js/misc/config.js
override_dh_install-arch:
dh_install -X.la --list-missing
override_dh_girepository:
dh_girepository -l src /usr/lib/$(DEB_HOST_MULTIARCH)/cinnamon
override_dh_strip:
dh_strip --dbgsym-migration='cinnamon-dbg (<< 3.0.2-1~)' || dh_strip
override_dh_makeshlibs:
dh_makeshlibs -pcinnamon -Xlibcinnamon
dh_makeshlibs --remaining-packages
|