1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83
|
pkg := cl-ppcre
debpkg := cl-ppcre
DESTDIR := debian/$(debpkg)
clc-source := usr/share/common-lisp/source
clc-systems := usr/share/common-lisp/systems
clc-ppcre := $(clc-source)/$(pkg)
doc-dir := usr/share/doc/$(debpkg)
configure: configure-stamp
configure-stamp:
dh_testdir
touch configure-stamp
build: build-stamp
build-stamp: configure-stamp
dh_testdir
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
rm -f debian/cl-ppcre.postinst.* debian/cl-ppcre.prerm.*
dh_clean
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs $(clc-systems) $(clc-ppcre) $(doc-dir)
dh_install *.asd $(shell echo *.lisp) $(clc-ppcre)
chmod 0644 $(DESTDIR)/$(clc-ppcre)/*
binary-arch: build install
binary-indep: build install
dh_testdir
dh_testroot
dh_installdocs doc/index.html
dh_installchangelogs -k CHANGELOG
dh_lisp
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure
|