File: changelog

package info (click to toggle)
clazy 1.5-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 3,804 kB
  • sloc: cpp: 18,333; python: 1,100; sh: 223; makefile: 25
file content (71 lines) | stat: -rw-r--r-- 2,889 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
clazy (1.5-1) unstable; urgency=medium

  * New upstream release.
  * Update the patches:
    - upstream_Fix-clazy-list-not-listing-the-correct-doc-directory.patch:
      drop, backported from upstream
    - upstream_docs-add-empty-line-between-encoding-and-head1-NAME.patch: drop,
      backported from upstream
    - upstream_Fix-installation-of-clazy-wrapper-scripts.patch: drop,
      backported from upstream
    - upstream_inefficient-qlist-Use-64-as-the-limit-instead-of-siz.patch:
      drop, backported from upstream
    - debian-tests-link-atomic.diff: refresh
    - select-clangpp.diff: update to the new upstream version, and simplify
  * Update copyright.
  * Add qtdeclarative5-dev as build dependency, and as dependency for the
   'run-tests' autopkgtest, as it is needed by the test suite.
  * Update lintian overrides.
  + Bump Standards-Version to 4.3.0, no changes required.

 -- Pino Toscano <pino@debian.org>  Wed, 06 Feb 2019 22:26:46 +0100

clazy (1.4-4) unstable; urgency=medium

  [ Lisandro Damián Nicanor Pérez Meyer ]
  * Fix typo in debian/rules.

  [ Pino Toscano ]
  * Ensure that clazy uses, and requires the same Clang used at build time:
    (Closes: #915390)
    - add a way to enforce a specific clang++ executable; patch
      select-clangpp.diff
    - specify the clang++ executable of the default Clang version
    - depend on the clang package providing the selected clang++ executable

 -- Pino Toscano <pino@debian.org>  Tue, 18 Dec 2018 21:58:07 +0100

clazy (1.4-3) unstable; urgency=medium

  * Backport upstream commit 9713a15f65424f06e45c78fc1bf1c2d2b27f4e36 to use 64
    as the limit in inefficient-qlist (fixing the test suite on 32bit Linux
    architectures); patch
    upstream_inefficient-qlist-Use-64-as-the-limit-instead-of-siz.patch.
  * Make sure to link with atomic on armel, both when building, and when
    linking the tests.

 -- Pino Toscano <pino@debian.org>  Sun, 02 Dec 2018 10:36:29 +0100

clazy (1.4-2) unstable; urgency=medium

  * Backport upstream commit 8ad500134416b960b3c28146e7245b7403f4c851 to
    properly install the clazy wrapper script as executable; patch
    upstream_Fix-installation-of-clazy-wrapper-scripts.patch.
  * Fix the execution of the test suite:
    - make the clazy wrapper script executable in the build directory, so it
      can be run
    - add the top-level build directory to $PATH, so that the clazy script
      is found
  * Fix Vcs-Git field to its non-redirecting version.
  * 'run-tests' autopkgtest: query clang/clang++ for their basic facts (like
    include/library paths, etc), so it is easier to debug test failures.

 -- Pino Toscano <pino@debian.org>  Tue, 27 Nov 2018 07:27:10 +0100

clazy (1.4-1) unstable; urgency=medium

  [ Scarlett Clark ]
  [ Pino Toscano ]
  * Initial release (Closes: #886883)

 -- Scarlett Clark <sgclark@kde.org>  Sun, 04 Nov 2018 22:03:44 +0100