1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
|
include /usr/share/javahelper/java-vars.mk
include /usr/share/dpkg/pkg-info.mk
export LEIN_HOME=$(CURDIR)/.lein
export LEIN_OFFLINE=true
UPSTREAM_VERSION := $(shell echo $(DEB_VERSION_UPSTREAM) | sed -e 's/\+dfsg//')
NAME=digest
%:
dh $@ --with javahelper --with maven_repo_helper
override_dh_auto_configure:
cd debian && ln -sf /usr/share/maven-repo .
override_dh_auto_build:
lein pom debian/pom.xml
lein jar
cd target && ln -sf $(NAME)-$(UPSTREAM_VERSION).jar $(NAME).jar
cd target && ln -sf $(NAME)-$(UPSTREAM_VERSION).jar clj-$(NAME).jar
override_dh_auto_test:
cp debian/patches/debian.png test/debian.png
lein test
override_jh_installlibs:
jh_installlibs target/$(NAME).jar
jh_installlibs target/clj-$(NAME).jar
override_dh_clean:
rm -f debian/maven-repo
rm -Rf target
rm -f debian/pom.xml
rm -f test/debian.png
dh_clean
|