1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
|
Source: clojure
Section: devel
Priority: optional
Maintainer: Debian Clojure Maintainers <pkg-clojure-maintainers@lists.alioth.debian.org>
Uploaders: Elana Hashman <ehashman@debian.org>
Build-Depends:
ant,
debhelper (>= 11),
default-jdk | openjdk-11-jdk,
javahelper,
libcore-specs-alpha-clojure (>= 0.2.44-2),
libspec-alpha-clojure (>= 0.2.176-2),
maven-repo-helper,
rename
Standards-Version: 4.3.0
Vcs-Git: https://salsa.debian.org/clojure-team/clojure.git
Vcs-Browser: https://salsa.debian.org/clojure-team/clojure
Homepage: http://clojure.org
Package: clojure
Architecture: all
Depends:
default-jre-headless | java8-runtime-headless | openjdk-11-jre-headless,
libclojure-java (= ${binary:Version}),
${misc:Depends}
Recommends: rlwrap
Breaks: clojure1.8 (<< 1.8.0-6)
Replaces: clojure1.8 (<< 1.8.0-6)
Description: Lisp dialect for the JVM
Clojure is a dynamic programming language that targets the Java Virtual
Machine. It is designed to be a general-purpose language, combining the
approachability and interactive development of a scripting language with
an efficient and robust infrastructure for multithreaded programming.
Clojure is a compiled language - it compiles directly to JVM bytecode,
yet remains completely dynamic. Every feature supported by Clojure is
supported at runtime. Clojure provides easy access to the Java
frameworks, with optional type hints and type inference, to ensure that
calls to Java can avoid reflection.
.
Clojure is a dialect of Lisp, and shares with Lisp the code-as-data
philosophy and a powerful macro system. Clojure is predominantly a
functional programming language, and features a rich set of immutable,
persistent data structures. When mutable state is needed, Clojure offers
a software transactional memory system and reactive Agent system that
ensure clean, correct, multithreaded designs.
Package: libclojure-java
Architecture: all
Depends:
libjsr166y-java,
${java:Depends},
${misc:Depends}
Breaks: clojure (<< 1.9.0-3), clojure1.8 (<< 1.8.0-6), libclojure1.8-java (<< 1.8.0-6)
Replaces: clojure (<< 1.9.0-3), clojure1.8 (<< 1.8.0-6), libclojure1.8-java (<< 1.8.0-6)
Section: java
Description: Lisp dialect for the JVM (library)
Clojure is a dynamic programming language that targets the Java Virtual
Machine. It is designed to be a general-purpose language, combining the
approachability and interactive development of a scripting language with
an efficient and robust infrastructure for multithreaded programming.
Clojure is a compiled language - it compiles directly to JVM bytecode,
yet remains completely dynamic. Every feature supported by Clojure is
supported at runtime. Clojure provides easy access to the Java
frameworks, with optional type hints and type inference, to ensure that
calls to Java can avoid reflection.
.
Clojure is a dialect of Lisp, and shares with Lisp the code-as-data
philosophy and a powerful macro system. Clojure is predominantly a
functional programming language, and features a rich set of immutable,
persistent data structures. When mutable state is needed, Clojure offers
a software transactional memory system and reactive Agent system that
ensure clean, correct, multithreaded designs.
.
This package contains the library.
|