1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
|
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
include /usr/share/dpkg/architecture.mk
%:
dh $@ --without autoreconf
override_dh_auto_configure:
./configure --prefix=/usr --libdir=/usr/lib/$(DEB_HOST_MULTIARCH) \
--build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) \
--enable-static --enable-dot --enable-dependency-linking
override_dh_auto_build-indep:
make doxydoc
$(RM) doxydoc/html/*.md5 doxydoc/html/*.dot doxydoc/html/*.map
override_dh_auto_test-indep:
execute_before_dh_installdocs-indep:
for F in $$(find doxydoc/html -name "*.html"); do\
sed -i "s,$(CURDIR)/,," $$F;\
done
execute_before_dh_installexamples:
sed -i -e "s,prefix-map=$(CURDIR),prefix-map=BUILDPATH,g" Cgl/examples/Makefile
|