File: changelog

package info (click to toggle)
coinor-osi 0.107.9+repack1-1
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 3,936 kB
  • ctags: 2,421
  • sloc: cpp: 39,325; sh: 8,785; makefile: 352
file content (149 lines) | stat: -rw-r--r-- 5,018 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
coinor-osi (0.107.9+repack1-1) unstable; urgency=medium

  * Upload into unstable.

 -- Anton Gladky <gladk@debian.org>  Mon, 21 Aug 2017 21:25:56 +0200

coinor-osi (0.107.9+repack1-1~exp1) experimental; urgency=medium

  * [f698d92] New upstream version 0.107.9+repack1
  * [18089a9] Remove autotools from build-depends.
  * [583e913] Set Standards-Version: 4.0.0
  * [624406e] Update version of dependend coinor-libcoinutils-dev

 -- Anton Gladky <gladk@debian.org>  Sat, 19 Aug 2017 23:50:32 +0200

coinor-osi (0.107.8+repack1-1~exp1) experimental; urgency=medium

  * [a31a3cc] Update d/watch
  * [0de8ecf] Remove MSVisualStudio from the package.
  * [a42d329] New upstream version 0.107.8+repack1
  * [e35ed98] Remove patch, applied by upstream.
  * [e436a98] Add myself as uploader.
  * [1b2e5d4] Remove Miles Lubin from uploaders. (Closes: #862819)
  * [8c478d6] Remove dbg-package.
  * [2b96336] Use compat level 10.
  * [76a9ed8] Apply cme fix dpkg.
  * [ba35c92] Apply maximal hardening.
  * [b9fd2f1] Add --without autoreconf to dh-options.
  * [50a2af0] Fix typo in changelog.
  * [f15ce99] Fix package name in override.
  * [57dfe60] Update minimal coinutils version in dependencies.

 -- Anton Gladky <gladk@debian.org>  Sat, 03 Jun 2017 21:29:19 +0200

coinor-osi (0.106.9-2) unstable; urgency=medium

  * libstdc++6 transition: rename coinor-libosi1 to coinor-libosi1v5
    and coinor-libosi1-dbg to coinor-libosi1v5-dbg (closes: #796715)
  * bump coinor-libcoinutils-dev build-dep

 -- Rene Engelhard <rene@debian.org>  Tue, 25 Aug 2015 12:51:04 +0200

coinor-osi (0.106.9-1) unstable; urgency=low

  * New upstream version.
  * Use dh_autotools-dev to update config.{sub,guess} for new ports.
    - Thanks to Adam Conrad
  * Remove shlibdeps patch incorporated upstream with configure option

 -- Miles Lubin <miles.lubin@gmail.com>  Tue, 02 Sep 2014 21:22:25 -0400

coinor-osi (0.106.4-1) unstable; urgency=low

  * New upstream version.
  * Switch to upstream's packager-friendly tarballs.
  * Bump standards version (no changes needed).
  * Upload to unstable for transition.

 -- Miles Lubin <miles.lubin@gmail.com>  Wed, 27 Nov 2013 23:33:22 -0500

coinor-osi (0.106.1-2) experimental; urgency=low

  * Update package descriptions from upstream.
  * Add missing dependency on libjs-jquery. 
    - Thanks to Paul Richards Tagliamonte.
  * Remove .la files.
  * Update copyright file.
    - Previous maintainer refused to relicense under EPL.
  * Patch libOsi to properly set shared library dependencies.
    - libOsiCommonTests still has missing symbols, but
      is not user facing.

 -- Miles Lubin <miles.lubin@gmail.com>  Mon, 30 Sep 2013 00:03:26 -0400

coinor-osi (0.106.1-1) experimental; urgency=low

  * New upstream version (Closes: #687261)
    - License changed to EPL.
    - SONAME version is now 1.
  * New maintainer (Closes: #645085)
  * Rewrite rules using dh.
  * Bump to compat 9 (libraries now installed to multiarch dirs.).
  * Bump standards version.
    - Updated copyright file to machine-readable format.
  * No longer depends on clp, coinor-vol, coinor-dylp.
    - Following upstream reorganization, these packages now
      depend on OSI and provide their own interfaces.
  * Remove outdated patches.
  * Add patch to fix building with pkg-config.

 -- Miles Lubin <miles.lubin@gmail.com>  Fri, 06 Sep 2013 00:02:20 -0400

coinor-osi (0.103.0-1) unstable; urgency=low

  * New upstream version.
    - Bump Standards-Version (no changes needed).
    - Build depend on clp >= 1.12.0 and dylp >= 1.6.0.

 -- Soeren Sonnenburg <sonne@debian.org>  Sat, 10 Jul 2010 09:10:08 +0200

coinor-osi (0.102.3-1) unstable; urgency=low

  * New upstream version.

 -- Soeren Sonnenburg <sonne@debian.org>  Mon, 17 May 2010 18:13:20 +0200

coinor-osi (0.102.2-1) unstable; urgency=low

  * New upstream version.
    - Switch to dpkg-source 3.0 (quilt) format.

 -- Soeren Sonnenburg <sonne@debian.org>  Sun, 11 Apr 2010 09:17:11 +0200

coinor-osi (0.102.1-1) unstable; urgency=low

  * New upstream version (Closes: #571392)
  * Bump Standards-Version (no changes needed).
  * Build depend on coinor-libcoinutils-dev >= 2.6.0-2, clp >= 1.11.0

 -- Soeren Sonnenburg <sonne@debian.org>  Fri, 26 Feb 2010 17:25:38 +0100

coinor-osi (0.100.2-1) unstable; urgency=low

  * New upstream version.
  * Refresh patches.

 -- Soeren Sonnenburg <sonne@debian.org>  Wed, 14 Oct 2009 07:33:03 +0200

coinor-osi (0.100.1-1) unstable; urgency=low

  [ Soeren Sonnenburg ]
  * New upstream version.
  * Refresh patches.
  * Fix override disparity by moving coinor-libosi0-dbg into section debug
  libdevel

  [ Aramian Wasielak ]
  * debian/control:
    - Bump Standards-Version (no changes needed).
  * debian/copyright:
    - Small formatting changes.

 -- Soeren Sonnenburg <sonne@debian.org>  Thu, 24 Sep 2009 16:15:40 +0200

coinor-osi (0.100.0-1) unstable; urgency=low

  * Initial Release. (Closes: #510148)

 -- Aramian Wasielak <aramian.wasielak@gmail.com>  Sun, 19 Apr 2009 08:08:24 +0200