1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380
|
include /usr/share/dpkg/architecture.mk
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
CPPFLAGS = $(shell dpkg-buildflags --get CPPFLAGS)
CPPFLAGS += -I$(CURDIR)/debian/include
CFLAGS = $(shell dpkg-buildflags --get CFLAGS)
CFLAGS += -Wall -Wno-error=deprecated-declarations
CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
CXXFLAGS += -Wall -Wno-error=deprecated-declarations
TEST_GCC_VER_9 := $(shell expr `$(CC) -dumpversion | cut -f1 -d.` \>= 9)
ifeq ($(TEST_GCC_VER_9),1)
CFLAGS += -Wno-error=address-of-packed-member -Wno-stringop-truncation -Wno-cpp -Wno-error=format-truncation
endif
CPPFLAGS += -UCONFIGFILE
CPPFLAGS += -DCONFIGFILE='\"/etc/collectd/collectd.conf\"'
# A PostgreSQL header redefines CACHE_LINE_SIZE on FreeBSD.
# Cf. https://bugs.debian.org/760719 and https://bugs.debian.org/763098
ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
CPPFLAGS += -Wp,-w
endif
LDFLAGS = $(shell dpkg-buildflags --get LDFLAGS)
# grpc workaround
ifneq (,$(filter $(DEB_HOST_ARCH), armel mips mipsel powerpc))
LDFLAGS += -Wl,--no-as-needed -latomic -Wl,--as-needed
endif
# The archdir map has been copied from openjdk-6's debian/rules.
JAVA_ARCHDIR = $(shell /usr/share/javahelper/java-arch.sh $(DEB_BUILD_ARCH))
ifeq (,$(JAVA_ARCHDIR))
JAVA_ARCHDIR = $(DEB_BUILD_ARCH)
endif
JAVA_HOME = /usr/lib/jvm/default-java
JAVA_LIBDIR = $(JAVA_HOME)/jre/lib/$(JAVA_ARCHDIR)/server
JAVAC = $(JAVA_HOME)/bin/javac
JAR = $(JAVA_HOME)/bin/jar
JAVA_CPPFLAGS = -I$(JAVA_HOME)/include
JAVA_LDFLAGS = -L$(JAVA_LIBDIR) -Wl,-rpath -Wl,$(JAVA_LIBDIR)
confflags = --host=$(DEB_HOST_GNU_TYPE) \
--build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr \
--mandir=\$${prefix}/share/man \
--localstatedir=/var --sysconfdir=/etc \
--with-perl-bindings="INSTALLDIRS=vendor INSTALL_BASE=" \
--without-libstatgrab \
--disable-static \
--disable-silent-rules \
--enable-all-plugins
# disable tokyotyrant (#980331)
confflags += --disable-tokyotyrant
# These plugins do not provide any functionality under Linux.
# MacOS only (requires IO Kit):
confflags += --disable-apple_sensors
# AIX only (requires perfstat):
confflags += --disable-lpar
# Solaris only (requires devinfo and kstat)
confflags += --disable-tape
# redfish.h is missing
confflags += --disable-redfish
# pmw_api.h is missing
confflags += --disable-dcpmm
# libaquaero5 is required for the aquaero plugin
confflags += --disable-aquaero
# libjevents is required for the intel_pmu plugin
confflags += --disable-intel_pmu
# libmic is required for the mic plugin
confflags += --disable-mic
# libnetapp is required for the netapp plugin.
confflags += --disable-netapp
# libclntsh is required for the oracle plugin.
confflags += --disable-oracle
# librouteros is required for the routeros plugin.
confflags += --disable-routeros
# xmms1 is required for the xmms plugin.
confflags += --disable-xmms
# libslurm doesn't have a pkg-config file in Debian
confflags += --disable-slurm
# libsigrok4 incompatible with the plugin.
# Cf. https://github.com/collectd/collectd/issues/1574
confflags += --disable-sigrok
# libnvidia-ml is non-free
confflags += --disable-gpu_nvidia
# disable nut plugin for now.
# nut is not in testing, see #937169 #885358
confflags += --disable-nut
# ganglia FTBS, disable it for now
# see #964399
confflags += --disable-gmond
# These plugins are Linux-specific.
ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
confflags += \
--disable-barometer \
--disable-cgroups \
--disable-cpusleep \
--disable-drbd \
--disable-ethstat \
--disable-fhcount \
--disable-hugepages \
--disable-ipc \
--disable-iptables \
--disable-ipvs \
--disable-madwifi \
--disable-md \
--disable-netlink \
--disable-numa \
--disable-sensors \
--disable-vserver
endif
# These plugins art FreeBSD-specific.
ifneq ($(DEB_HOST_ARCH_OS),kfreebsd)
confflags += \
--disable-pf \
--disable-ipstats \
--disable-netstat_udp
endif
# intel only stuff
ifeq (,$(filter $(DEB_HOST_ARCH),amd64 i386))
confflags += --disable-capabilities
confflags += --disable-dpdk_telemetry
endif
# This plugin is Solaris-specific.
confflags += \
--disable-zone
# These plugins have not been ported to FreeBSD yet.
ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
# Work-around an incomplete check for kvm functionality
CPPFLAGS += -DHAVE_STRUCT_KINFO_PROC_FREEBSD
confflags += --enable-processes=force
confflags += \
--disable-battery \
--disable-conntrack \
--disable-contextswitch \
--disable-cpufreq \
--disable-entropy \
--disable-fscache \
--disable-irq \
--disable-nfs \
--disable-protocols \
--disable-serial \
--disable-synproxy \
--disable-thermal \
--disable-vmem \
--disable-wireless
endif
# Build-dependencies of these plugins are (not yet) available for kfreebsd.
ifeq ($(DEB_HOST_ARCH_OS),kfreebsd)
confflags += \
--disable-gmond \
--disable-virt \
--disable-java
endif
# These plugins are Intel-hardware specific.
ifeq (,$(filter amd64 i386, $(DEB_HOST_ARCH)))
confflags += \
--disable-dpdkevents \
--disable-dpdkstat \
--disable-intel_pmu \
--disable-intel_rdt \
--disable-mcelog \
--disable-mic \
--disable-turbostat
endif
# the pcie_errors plugin does not work on all kinds of hardware
ifeq (,$(filter amd64 arm64 armel armhf i386 mips64el mipsel ppc64el, $(DEB_HOST_ARCH)))
confflags += \
--disable-pcie_errors
endif
# This plugin is x86 and arm specific.
ifeq (,$(filter amd64 arm64 armhf i386, $(DEB_HOST_ARCH)))
confflags += \
--disable-xencpu
endif
# libatasmart isn't available on these platforms.
ifneq (,$(filter hurd kfreebsd,$(DEB_HOST_ARCH_OS)))
confflags += --disable-smart
endif
# The hppa buildds currently do not keep up with Java related stuff, thus
# prevending testing transitions. sparc is also having trouble building the
# java plugin.
ifneq (,$(filter hppa sparc, $(DEB_HOST_ARCH)))
confflags += --disable-java
endif
# gRPC is only available on x86, arm, ppc.
ifeq (,$(filter amd64 arm64 armel armhf i386 mips64el mipsel ppc64el s390x, $(DEB_HOST_ARCH)))
confflags += --disable-grpc
endif
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp:
dh_testdir
dh_autoreconf
CXXFLAGS="$(CXXFLAGS)" CPPFLAGS="$(CPPFLAGS)" CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
JAVAC="$(JAVAC)" JAR="$(JAR)" JAVA_CPPFLAGS="$(JAVA_CPPFLAGS)" \
JAVA_LDFLAGS="$(JAVA_LDFLAGS)" \
./configure $(confflags) \
|| ( status=$$?; cat config.log; exit $$status )
$(MAKE)
dh_auto_test
perl ./debian/bin/check_plugins.pl
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
[ ! -f Makefile ] || $(MAKE) distclean
rm -f debian/README.Debian.plugins
rm -f src/*.1 src/*.5
rm -rf debian/pkgconfig
dh_autoreconf_clean
dh_clean
debconf-updatepo
install-indep:
dh_testdir
dh_testroot
dh_prep
dh_installdirs -i
set -e ;\
find src -path src/libcollectdclient -prune -o -path src/liboconfig -prune -o -name '*.h' -print | while read i; do \
d=$$(echo "$${i}" | sed 's,^src,debian/tmp/usr/include/collectd/core,') ;\
mkdir -p $$(echo "$${i}" | sed -e 's,^src,debian/tmp/usr/include/collectd/core,' -e 's,/[^/]*$$,,') ;\
cp "$${i}" "$${d}" ;\
done
dh_install -i
# update include path for collectd header files
( set -e; \
cd $(CURDIR)/debian/collectd-dev/usr/include/collectd/; \
headers=$$(find . -type f -name '*.h'); \
for lib in $$headers; do \
libname=$$(basename $$lib); \
fullpath=$$(echo $$lib | sed -r -e 's,^\./,collectd/,'); \
sed -r -i -e "s,(include\s+)\".*\<$$libname\",\1\"$$fullpath\"," $$headers; \
done )
install-arch: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs -a
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
rm -f debian/tmp/usr/lib/collectd/*.la
rm -f debian/tmp/usr/lib/libcollectdclient.la
rm -f debian/tmp/etc/collectd.conf
dh_install -a --sourcedir=$(CURDIR)/debian/tmp --fail-missing
perl ./debian/bin/gen_plugin_deps.pl
mkdir -p debian/collectd-core/usr/share/lintian/overrides/
cp debian/collectd-core.overrides \
debian/collectd-core/usr/share/lintian/overrides/collectd-core
binary-indep: install-indep
dh_testdir
dh_testroot
dh_installchangelogs -i ChangeLog
dh_installdocs -A -i debian/README.Debian AUTHORS README
dh_installexamples -i contrib/examples/myplugin.c \
contrib/examples/MyPlugin.pm
dh_compress -i -Xexamples/
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
binary-arch: build install-arch
dh_testdir
dh_testroot
dh_installchangelogs -a ChangeLog
dh_installdocs -A -a debian/README.Debian AUTHORS README
dh_installdocs -a debian/NEWS debian/README.Debian.plugins
dh_installexamples -a contrib/collectd2html.pl contrib/collection.cgi \
contrib/collection3/ contrib/php-collection/ \
contrib/exec-munin.conf contrib/exec-munin.px contrib/exec-smartctl \
contrib/exec-nagios.conf contrib/exec-nagios.px contrib/exec-ksm.sh \
contrib/SpamAssassin/ contrib/iptables/ contrib/cussh.pl \
contrib/snmp-data.conf contrib/add_rra.sh contrib/network-proxy.py \
contrib/collectd_network.py contrib/collectd_unixsock.py \
contrib/snmp-probe-host.px contrib/GenericJMX.conf \
contrib/postgresql \
debian/collectd.conf debian/filters.conf debian/thresholds.conf
( cd debian/collectd-core/ \
&& cd usr/share/doc/collectd-core/examples/collection3/ \
&& rm -f bin/foo bin/test_config.px etc/collection4.conf \
&& rm -f lib/Collectd/Graph.pm lib/Collectd/Graph/Data.pm \
&& rm -f lib/Collectd/Graph/File.pm lib/Collectd/Graph/Filter.pm \
&& rm -f lib/Collectd/Graph/MetaData.pm )
dh_installdebconf -a
dh_systemd_enable -pcollectd-core --name=collectd
dh_installinit -pcollectd-core --name=collectd -- defaults 95
dh_systemd_start -pcollectd-core
dh_link -a
dh_strip -a --dbgsym-migration='collectd-dbg (<< 5.9.2.g-2~)'
dh_strip_nondeterminism -pcollectd-core
dh_compress -a -Xexamples/
dh_fixperms -a
dh_makeshlibs -a
dh_installdeb -a
dh_shlibdeps -a -Ncollectd-core -Ncollectd
dpkg-shlibdeps -Tdebian/collectd.substvars \
-dDepends debian/collectd-core/usr/lib/collectd/rrdtool.so
dpkg-shlibdeps -Tdebian/collectd-core.substvars \
-dDepends debian/collectd-core/usr/sbin/* \
-dSuggests debian/collectd-core/usr/lib/collectd/*.so
grep shlibs:Suggests debian/collectd-core.substvars \
| sed -e 's/shlibs:Suggests/shlibs:Recommends/' \
>> debian/collectd.substvars
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
binary: binary-arch binary-indep
.PHONY: build build-arch build-indep clean binary-indep binary-arch binary install-indep install-arch
|