File: changelog

package info (click to toggle)
commons-vfs 2.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 6,568 kB
  • sloc: java: 31,470; xml: 4,212; sh: 68; makefile: 4
file content (177 lines) | stat: -rw-r--r-- 6,204 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
commons-vfs (2.1-2) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure with Java 9 (Closes: #875353)
  * Standards-Version updated to 4.1.3
  * Switch to debhelper level 11
  * Fixed the watch file

 -- Emmanuel Bourg <ebourg@apache.org>  Fri, 09 Mar 2018 12:16:40 +0100

commons-vfs (2.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
    - Refreshed the patches
    - Disabled the new HDFS provider (missing dependencies)
    - Depend on commons-collections4 instead of commons-collections3
    - Ignore the new test dependencies
  * Moved the package to Git
  * Standards-Version updated to 3.9.8

 -- Emmanuel Bourg <ebourg@apache.org>  Thu, 07 Jul 2016 01:09:47 +0200

commons-vfs (2.0-7) unstable; urgency=medium

  * Team upload.
  * Fixed the build failure with commons-parent 39 (enables the OSGI metadata)
    (Closes: #811259)

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 18 Jan 2016 08:59:11 +0100

commons-vfs (2.0-6) unstable; urgency=medium

  * Team upload.
  * Added the missing dependency on libjackrabbit-java (Closes: #808638)

 -- Emmanuel Bourg <ebourg@apache.org>  Wed, 30 Dec 2015 17:45:54 +0100

commons-vfs (2.0-5) unstable; urgency=medium

  * Team upload.
  * Depend on libcommons-net-java instead of libcommons-net2-java
    (Closes: #800761)
  * Build with the DH sequencer instead of CDBS

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 07 Dec 2015 11:34:18 +0100

commons-vfs (2.0-4) unstable; urgency=medium

  * Team upload.
  * Ignore the dependency on maven-scm (Closes: #797459)
  * Standards-Version updated to 3.9.6 (no changes)
  * Use canonical URLs for the Vcs-* fields
  * Switch to debhelper level 9
  * debian/copyright: Updated the Format URI

 -- Emmanuel Bourg <ebourg@apache.org>  Mon, 31 Aug 2015 16:07:05 +0200

commons-vfs (2.0-3) unstable; urgency=low

  * Team upload.
  * Explicitly state the encoding used to fix FTBFS with Java7.

 -- Niels Thykier <niels@thykier.net>  Wed, 20 Jun 2012 17:57:31 +0200

commons-vfs (2.0-2) unstable; urgency=low

  * Update Standard-Version: 3.9.3.
  * Install JAR into /usr/share/java (Closes: #667011).
  * Drop --no-parent option and add Build-Depends on libcommons-parent-
    java.

 -- Damien Raude-Morvan <drazzib@debian.org>  Sun, 08 Apr 2012 18:19:31 +0200

commons-vfs (2.0-1) unstable; urgency=low

  * New upstream release:
    - Drop all previous patches.
    - d/control: Build-Depends on libcommons-net2-java, junit4,
      libcommons-compress-java.
  * Bump Standards-Version 3.9.2: no changes needed.
  * d/copyright: Use DEP-5 format.
  * Switch to Maven build system:
    - d/patches/skip_examples.diff: Don't build examples module.
    - d/patches/disable_webdav_provider.diff: Disable webdav provider.
    - Drop B-D on ant, but add B-D on maven-debian-helper
    - Use ${maven:Depends} and ${maven:OptionalDepends} for Depends
      and Recommends.
  * d/docs: Update for new release.

 -- Damien Raude-Morvan <drazzib@debian.org>  Sun, 11 Sep 2011 00:44:27 +0200

commons-vfs (1.0-6) unstable; urgency=low

  * Team upload

  [ Damien Raude-Morvan ]
  * d/control: Drop Depends on any JRE as a Java library don't need to
    depends on a runtime (Java Policy)

  [ Torsten Werner ]
  * Change 'maintainers' into 'Maintainers'.
  * Update Standard-Version: 3.9.1.
  * Switch to source format 3.0.

 -- Torsten Werner <twerner@debian.org>  Tue, 30 Aug 2011 16:56:07 +0200

commons-vfs (1.0-5) unstable; urgency=low

  * debian/maven.rules:
    - fix jdom groupId to org.jdom
    - use 3.x release of commons-httpclient
    - use 1.x release of commons-net
  * Update my email address
  * Bump debhelper version to >= 7

 -- Damien Raude-Morvan <drazzib@debian.org>  Sat, 12 Dec 2009 22:02:48 +0100

commons-vfs (1.0-4) unstable; urgency=low

  * Set Maintainer field to Debian Java Team
  * Add myself as Uploaders
  * Add ${misc:Depends} in Depends field for debhelper
  * Bump Standards-Version 3.8.3:
    - Move libcommons-vfs-java to "java" section
    - Add a README.source describing patch system
  * Switch to Quilt patch system:
    - Refresh all patchs
    - Add B-D on quilt
    - Include patchsys-quilt.mk in debian/rules
  * New patch 02_no_home_dir.diff: don't try to create/copy files
    in $HOME as many autobuilder won't have one
  * Use default-jdk/jre:
    - Depends on default-jre-headless instead of java-gcj-compat
    - Build-Depends on default-jdk instead of default-jdk-builddep
      because we don't build a native GCJ package.
  * Maven POMs:
    - Add a Build-Depends-Indep dependency on maven-repo-helper
    - Use mh_installpom and mh_installjar to install the POM and the jar to the
      Maven repository
  * Move api documentation to /usr/share/doc/libcommons-vfs-java/api

 -- Damien Raude-Morvan <drazzib@drazzib.com>  Sun, 23 Aug 2009 00:52:26 +0200

commons-vfs (1.0-3) unstable; urgency=low

  * debian/control:
    - Build-Depend on default-jdk-builddep instead of java-gcj-compat-dev.
    - Move default-jdk-builddep form B-D-I to B-D (needed for clean)
    - Differentiate short description of -doc package
  * debian/rules: Use default-java from default-jdk-builddep as JAVA_HOME
  * Move examples (sample source code) to libcommons-vfs-java-doc package

 -- Damien Raude-Morvan <drazzib@drazzib.com>  Sun, 30 Nov 2008 13:11:05 +0100

commons-vfs (1.0-2) unstable; urgency=low

  * debian/rules:
     - Include examples/ in libcommons-vfs-java
     - Install Javadoc API in /usr/share/doc/libcommons-vfs-java-doc
     - Use CDBS DEB_SOURCE_PACKAGE and DEB_UPSTREAM_VERSION instead of using
       dpkg-parsechangelog
     - get-orig-source: use --force-download for uscan
     - include simple-patchsys.mk rules before ant.mk class
  * debian/control:
     - Remove depends on java1-runtime as commons-vfs only works
       with Java >= 1.4
  * debian/copyright: Relicense debian packaging under BSD
  * debian/dirs: Removed because dirs are created by dh_install

 -- Damien Raude-Morvan <drazzib@drazzib.com>  Sun, 10 Aug 2008 21:55:32 +0200

commons-vfs (1.0-1) unstable; urgency=low

  * Initial release (closes: #238904).

 -- Damien Raude-Morvan <drazzib@drazzib.com>  Wed, 16 Jul 2008 21:56:34 +0200