File: singularitygs.gemspec

package info (click to toggle)
compass-singularitygs-plugin 1.8.0-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 592 kB
  • ctags: 15
  • sloc: ruby: 70; makefile: 29; sh: 4
file content (30 lines) | stat: -rw-r--r-- 1,145 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
# -*- encoding: utf-8 -*-
require './lib/singularitygs'

Gem::Specification.new do |s|
  # General Project Information
  s.name = "singularitygs"
  s.version = SingularityGS::VERSION
  s.date = SingularityGS::DATE
  s.rubyforge_project = "singularitygs"
  s.rubygems_version = "1.7.2"
  s.required_rubygems_version = Gem::Requirement.new(">= 1.2")

  # Author Information
  s.authors = ["Scott Kellum", "Sam Richard"]
  s.email = ["scott@scottkellum.com", "snugug@gmail.com"]
  s.homepage = "http://singularity.gs"
  s.licenses = ["MIT"]

  # Project Description
  s.description = "Advanced responsive grid system for Sass and Compass"
  s.summary = "Singularity is a fluid grid system that can generate uniform columns as well as asymmetric and compound grids. It is designed to be extensible, adding additional outputs or grid generators are easy, and the core syntax is simple to build upon for custom input syntaxes."

  # Files to Include
  s.files = Dir.glob("lib/*.*")
  s.files += Dir.glob("stylesheets/**/*.*")

  # Dependent Gems
  s.add_dependency 'sass',                "~> 3.3"
  s.add_dependency 'breakpoint',          "~> 2.4"
end