File: NEWS

package info (click to toggle)
conky 1.11.6-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 11,824 kB
  • sloc: xml: 89,480; cpp: 39,856; ansic: 2,340; python: 714; sh: 194; makefile: 130
file content (204 lines) | stat: -rw-r--r-- 8,238 bytes parent folder | download | duplicates (4)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
conky (1.10.0-1) unstable; urgency=medium

    Conky 1.10.0 introduces a new Lua-based configuration format, which
    supersedes the older free-form text format. An example can be found in
    /usr/share/doc/conky-{std,cli,all}/conky.conf, and documented at [1][2].
    You may attempt to convert your old conkyrc by using a Lua script that can
    be found at /usr/share/doc/conky-{std,cli,all}/convert.lua.

    Support for the older pre-1.10.0 conkyrc format will continue to be
    enabled in the Debian packages for as long as it is supported and
    maintained upstream.

    [1] https://github.com/brndnmtthws/conky/wiki/Configuration-Settings
    [2] https://github.com/brndnmtthws/conky/wiki/Configuration-Variables

 -- Vincent Cheng <vcheng@debian.org>  Tue, 30 Jun 2015 21:35:43 -0700

conky (1.9.0-5) unstable; urgency=medium

    src:conky-all has been merged into src:conky, including all binary
    packages built by the former (conky-all), now that libxnvctrl and
    nvidia-settings has been moved to main; see [#747837] for background wrt
    nvidia-settings, and [#579102] for rationale as to why the conky vs.
    conky-all source package split was necessary in the first place.

    For end users, this means that:
    - Support for RSS, weather (both METAR and XOAP), imlib2, and all Lua
      bindings are disabled in conky-std. These features (which are not
      enabled by default upstream) are all enabled in conky-all instead.
    - conky-all has been moved to main. You should install this package if
      you need the above features.

    This means that support for features in the various conky binary packages
    are effectively the same as in versions prior to 1.8.1-3 before the split.

    [#747837]: https://bugs.debian.org/747837
    [#579102]: https://bugs.debian.org/579102

 -- Vincent Cheng <vcheng@debian.org>  Sat, 30 Aug 2014 12:28:42 -0700

conky (1.8.1-3) unstable; urgency=low

    conky-std now includes support for RSS, weather (both METAR and XOAP),
    imlib2, and all Lua bindings. This is a compromise for users who do not
    wish to have contrib enabled on their systems to install conky-all, yet
    would like the most common features from the conky-all package.

    Also, both conky-all and conky-std now include support for Audacious
    and XMMS2.

 -- Vincent Cheng <Vincentc1208@gmail.com>  Wed, 10 Aug 2011 21:23:19 -0700

conky (1.8.0-1) unstable; urgency=low

    Package maintenance moved back to Debian.
    Debian users, please be aware that 3 binary packages are now created:
    conky-cli, conky-std and conky-all.

    conky-cli is a basic package that can be useful in servers or piped
    with dzen2.
    It includes the following support:

    MPD, MOC, math, apcupsd, ncurses and I/O stats

    conky-std should be a good compromise for most users that do not
    need special features.
    It includes the following support:

    X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon,
    wireless, ALSA mixer, apcupsd, I/O stats and lua

    conky-all includes almost all of the available support:

    X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon, RSS, curl,
    Weather (METAR and XOAP), wireless, IBM, nvidia, eve-online, Imlib2,
    ALSA mixer, apcupsd, I/O stats, Lua and Lua bindings for the cairo
    and imlib2 libraries.

    Note that some features might not be available for non-linux kernels
    or non i386, amd64 CPUs.

 -- Cesare Tirabassi <norsetto@ubuntu.com>  Fri, 12 Mar 2010 21:07:21 +0100

conky (1.8.0-0ubuntu1) lucid; urgency=low

    ncurses support has been enabled for the conky-cli package.

 -- Cesare Tirabassi <norsetto@ubuntu.com>  Sun, 24 Jan 2010 21:10:43 +0100

conky (1.7.2-0ubuntu2) karmic; urgency=low

    3 binary packages are now created: conky-cli, conky-std and conky-all.

    conky-cli is a basic package that can be useful in servers or piped
    with dzen2.
    It includes the following support:

    MPD, MOC, math, apcupsd and I/O stats

    conky-std should be a good compromise for most users that do not
    need special features.
    It includes the following support:

    X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon,
    wireless, ALSA mixer, apcupsd, I/O stats and lua

    conky-all includes almost all of the available support:

    X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon, RSS, curl,
    Weather (METAR and XOAP), wireless, IBM, nvidia, eve-online, Imlib2,
    ALSA mixer, apcupsd, I/O stats, Lua and Lua bindings for the cairo
    and imlib2 libraries.

 -- Cesare Tirabassi <norsetto@ubuntu.com>  Thu, 03 Sep 2009 17:47:02 +0200

conky (1.7.2-0ubuntu1) karmic; urgency=low

    3 binary packages are now created: conky-cli, conky and conky-all.

    conky-cli is a basic package that can be useful in servers or piped
    with dzen2.
    It includes the following support:

    MPD, MOC, math, apcupsd and I/O stats

    conky should be a good compromise for most users that do not
    need special features.
    It includes the following support:

    X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon,
    wireless, ALSA mixer, apcupsd, I/O stats and lua

    conky-all includes almost all of the available support:

    X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon, RSS, curl,
    Weather (METAR and XOAP), wireless, IBM, nvidia, eve-online, Imlib2,
    ALSA mixer, apcupsd, I/O stats, Lua and Lua bindings for the cairo
    and imlib2 libraries.

 -- Cesare Tirabassi <norsetto@ubuntu.com>  Fri, 24 Jul 2009 10:38:14 +0200

conky (1.7.0-0ubuntu1) karmic; urgency=low

    The sample version of the config file is not distributed anymore.
    A number of features and fixes have been added since the previous
    release as documented in the man page and the upstream changelog.

 -- Cesare Tirabassi <norsetto@ubuntu.com>  Sat, 16 May 2009 12:04:10 +0200

conky (1.5.1-1) unstable; urgency=low

    The system default config file for conky is an external
    conffile '/etc/conky/conky.conf' (since upstream version 1.4.9) 
    a sample version of this file is in the doc/examples directory.
    A number of features and fixes have been added since the previous
    release as documented in the man page and the upstream changelog.

 -- Kapil Hari Paranjape <kapil@debian.org>  Wed, 02 Apr 2008 06:50:26 +0530

conky (1.4.9-4) unstable; urgency=low

    Based on requests from some users and from the Ubuntu team the
    support for RSS feed monitoring has been enabled in this build.
 
 -- Kapil Hari Paranjape <kapil@debian.org>  Fri, 22 Feb 2008 06:19:29 +0530

conky (1.4.9-1) unstable; urgency=low

    Since enabling the wireless support meant adding "only" 62K of
    library dependency it has been enabled in this build.
 
 -- Kapil Hari Paranjape <kapil@debian.org>  Mon, 03 Dec 2007 09:24:31 +0530

conky (1.4.7-1) unstable; urgency=low

    The previous version of "conky" packaged for Debian was 1.4.4
    so there have been a number of changes to "conky" and its
    configuration in the intervening period. Please look at the
    upstream documentation (Changelog, NEWS, man pages) for further
    details.

    Some new config parameters have been added but if you have a
    configuration file for version 1.4.4-1 it should work without any
    problems with this version. If it does not, please report it as a
    bug to the Debian BTS.

    Some of the notable additions to "conky" are build-time options
    that support "audacious", "beep media player", "RSS feeds" and
    "wireless devices". These are *not* enabled in the current Debian
    packaging. Users who want these features will have to re-build
    "conky" with appropriate changes.

    The hard-coded default configuration of "conky" shows the tail of
    the file /var/log/Xorg.0.log. However, this causes "conky" to
    exit with an error for those users who do not have such a file or
    do not have access to it. The Debian version of "conky" disables
    this portion of the hard-coded configuration.

    One of the significant upstream changes is "Clarifying
    licensing". This is documented further in the "copyright" file in
    this directory.

 -- Kapil Hari Paranjape <kapil@debian.org>  Fri, 21 Sep 2007 06:24:31 +0530