1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36
|
export LC_ALL=C.UTF-8
export PYBUILD_NAME=pbconsensuscore
export DEB_BUILD_MAINT_OPTIONS=hardening=+all
export DEB_CFLAGS_MAINT_APPEND=-fopenmp-simd -DSIMDE_ENABLE_OPENMP -Wno-psabi -O3
export DEB_CXXFLAGS_MAINT_APPEND=-fopenmp-simd -DSIMDE_ENABLE_OPENMP -Wno-psabi -O3
%:
dh $@ --buildsystem=pybuild
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
$(MAKE) test
endif
execute_before_dh_auto_build:
test -f src/SWIG/numpy.i.orig || mv -v src/SWIG/numpy.i src/SWIG/numpy.i.orig
cp $(shell python3 -c 'import numpy;print(numpy.get_include())')/numpy/numpy.i src/SWIG/numpy.i
execute_before_dh_auto_clean:
! test -f src/SWIG/numpy.i.orig || mv -v src/SWIG/numpy.i.orig src/SWIG/numpy.i
execute_after_dh_python3:
dh_numpy3
execute_after_dh_install:
find debian -name meson.build -delete
|