1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
|
include /usr/share/dpkg/default.mk
PKG := github.com/containerd/containerd
TAGS := seccomp apparmor
GO_LDFLAGS += -X $(PKG)/version.Version=$(DEB_VERSION_UPSTREAM)
GO_LDFLAGS += -X $(PKG)/version.Revision=$(DEB_VERSION)
EXCLUDES += cmd/protoc-gen-gogoctrd cmd/containerd-stress
EXCLUDES += runtime/v2/example/cmd
CRI_FILE += cmd/containerd/builtins_cri.go vendor/github.com/containerd/cri
CRI_FILE += vendor/k8s.io vendor/github.com/docker/docker
CRI_FILE += vendor/github.com/containerd/imgcrypt
export DH_GOLANG_EXCLUDES := $(EXCLUDES)
%:
dh $@ --buildsystem=golang --with=golang --builddirectory=_build
override_dh_auto_build:
dh_auto_build -- -tags '$(TAGS)' -ldflags '$(GO_LDFLAGS)'
execute_after_dh_auto_build:
mkdir -p man
make man/containerd-config.8
make man/containerd-config.toml.5
_build/bin/gen-manpages containerd.8 man
_build/bin/gen-manpages ctr.8 man
rm -vf _build/bin/gen-manpages
sed 's|/usr/local/bin|/usr/bin|' containerd.service > debian/containerd.service
mkdir -vp debian/bash-completion
install -m644 -T /usr/share/gocode/src/github.com/urfave/cli/autocomplete/bash_autocomplete \
debian/bash-completion/ctr
mkdir -vp debian/zsh-completion
sed 's|$$PROG|ctr|g' /usr/share/gocode/src/github.com/urfave/cli/autocomplete/zsh_autocomplete > \
debian/zsh-completion/_ctr
override_dh_auto_test:
dh_auto_test -- -tags '$(TAGS)'
override_dh_auto_install:
DH_GOLANG_EXCLUDES="$(EXCLUDES) $(CRI_FILE)" dh_auto_install
|