File: README.win

package info (click to toggle)
coq-doc 8.2pl1-1
  • links: PTS, VCS
  • area: non-free
  • in suites: squeeze
  • size: 19,240 kB
  • ctags: 22,737
  • sloc: ml: 132,933; ansic: 1,960; sh: 1,366; lisp: 456; makefile: 327
file content (65 lines) | stat: -rw-r--r-- 2,265 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
THE COQ V8.2 SYSTEM
===================

    This file contains remarks specific to the Windows port of Coq.

INSTALLATION.
=============

    The Coq package for Windows comes with an auto-installer. It will
install Coq binaries and libraries under any directory you specify
(C:\Program Files\Coq is the default path). It also creates shortcuts
in the Windows menus. Alternatively, you can launch Coq using Coq.bat
and Coqide.bat in the installation directory (C:\Program Files\Coq by
default).

COMPILATION.
============

    If you want to install Coq, you had better transfer the precompiled
    distribution. If you really need to recompile under Windows, here
    are some indications:

    1- Install OCaml for Windows (MinGW port), preferably version 3.11.0.
       See: http://caml.inria.fr
     
       If you choose OCaml 3.11.0, you also need to install FlexDLL.
       See: http://alain.frisch.fr/flexdll.html    
  
       As shell script really dislikes space character within file
       names, we strongly advise you to install OCaml to a path not
       containing spaces, like 'C:\OCaml'

    2- Install a shell environment with at least:
         - a C compiler (gcc),
         - the GNU make utility

       The Cygwin environment is well suited for compiling Coq
       (official packages are made using Cygwin) See:
       http://www.cygwin.com

    3- If using OCaml version >= 3.10.0, you have to install Camlp5.
       See http://pauillac.inria.fr/~ddr/camlp5/

    4- In order to compile Coqide, you will need the LablGTK library
       See: http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html

       You also need to install the GTK libraries for Windows (see the
       installation instruction for LablGTK)

    5- In a shell window, type successively

        ./configure
        make world
        make install

    6- Though not nescessary, you can find useful:
         - Windows version of (X)Emacs: it is a powerful environment for
           developpers with coloured syntax, modes for compilation and debug,
           and many more. It is free. See: http://www.gnu.org/software.
         - Windows subversion client (very useful if you have access to the Coq
           archive).

    Good luck :-)

    The Coq Team.