File: control

package info (click to toggle)
courier-authlib 0.69.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 14,340 kB
  • sloc: ansic: 15,551; sh: 4,627; cpp: 4,172; makefile: 774; perl: 747
file content (115 lines) | stat: -rw-r--r-- 4,028 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
Source: courier-authlib
Section: mail
Priority: optional
Maintainer: Markus Wanner <markus@bluegap.ch>
Standards-Version: 4.3.0
Build-Depends: debhelper (>= 11),
               dh-autoreconf,
               pkg-kde-tools,
               default-libmysqlclient-dev,
               expect,
               libcourier-unicode-dev (>= 2.0),
               libgdbm-dev | libgdbmg1-dev,
               libidn11-dev,
               libldap-dev,
               libltdl3-dev,
               libpam0g-dev,
               libpq-dev,
               libsasl2-dev | libsasl-dev,
               libsqlite3-dev,
               libtool,
               pkg-config,
               procps
Homepage: https://www.courier-mta.org/
Vcs-Git: https://salsa.debian.org/debian/courier-authlib.git
Vcs-Browser: https://salsa.debian.org/debian/courier-authlib

Package: courier-authlib
Architecture: any
Depends: adduser,
         ${misc:Depends},
         ${shlibs:Depends}
Recommends: expect
Breaks: courier-base (<< 0.75.0-15),
        maildrop (<< 2.7.1-4)
Description: Courier authentication library
 The Courier authentication library provides authentication services
 for other Courier applications.

Package: courier-authdaemon
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         lsb-base (>= 3.0-10),
         sysvinit-utils (>= 2.88dsf-50) | init-d-script,
         ${misc:Depends},
         ${shlibs:Depends}
Description: Courier authentication daemon
 This package contains the authentication daemon for the Courier
 applications.

Package: courier-authlib-dev
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: Development libraries for the Courier authentication library
 This package contains the development libraries and files needed to
 compile Courier packages that use the Courier authentication library.

Package: courier-authlib-userdb
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: userdb support for the Courier authentication library
 This package contains the userdb support for the Courier
 authentication library. Userdb is a simple way to manage virtual mail
 accounts using a GDBM-based database file.

Package: courier-authlib-mysql
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: MySQL support for the Courier authentication library
 This package contains the MySQL support for the Courier
 authentication library.

Package: courier-authlib-postgresql
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: PostgreSQL support for the Courier authentication library
 This package contains the PostgreSQL support for the Courier
 authentication library.

Package: courier-authlib-ldap
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: LDAP support for the Courier authentication library
 This package contains the LDAP support for the Courier authentication
 library.

Package: courier-authlib-sqlite
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: SQLite 3 support for the Courier authentication library
 This package contains the SQLite 3 support for the Courier
 authentication library.

Package: courier-authlib-pipe
Architecture: any
Depends: courier-authlib (>= ${binary:Version}),
         ${misc:Depends},
         ${shlibs:Depends}
Description: External authentication support for the Courier authentication library
 This package contains external authentication support via pipes for
 the Courier authentication library. The authpipe module is a generic
 plugin that enables authentication requests to be serviced by an
 external program, then communicates through messages on stdin and
 stdout.