1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
include /usr/share/cdbs/1/rules/simple-patchsys.mk
include /usr/share/cdbs/1/rules/autoreconf.mk
export NOCONFIGURE=1
DEB_DH_AUTORECONF_ARGS += /usr/bin/gnome-autogen.sh
DEB_CONFIGURE_EXTRA_FLAGS += --disable-static CSC=/usr/bin/mono-csc
DEB_INSTALL_MANPAGES_cowbell += debian/cowbell.1
export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export MONO_SHARED_DIR=$(CURDIR)
install/cowbell::
/usr/bin/xsltproc --nonet -o debian/cowbell.1 \
/usr/share/xml/docbook/stylesheet/nwalsh/manpages/docbook.xsl \
debian/cowbell.1.xml
rm -f debian/cowbell/usr/lib/cowbell/libtaglibsharpglue.la \
debian/cowbell/usr/lib/cowbell/libtaglibsharpglue.a
common-binary-predeb-arch::
dh_clifixperms
dh_clideps -d
clean::
rm -rf $(MONO_SHARED_DIR)/.wapi
rm -f debian/cowbell.1
|