1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
CONFIGURE_OPTIONS = --with-arpack=/usr/lib/$(DEB_HOST_MULTIARCH) --with-fftw3=/usr/lib/$(DEB_HOST_MULTIARCH) --with-readline=/usr/lib/$(DEB_HOST_MULTIARCH)
ifeq ($(shell test -e /usr/include/OpenMM.h && echo YES),YES)
CONFIGURE_OPTIONS += --with-openmm=/usr/lib/$(DEB_HOST_MULTIARCH)
endif
%:
dh $@
override_dh_auto_configure:
./configure gnu $(CONFIGURE_OPTIONS)
override_dh_auto_test:
dh_auto_test -- check unittest
$(MAKE) -C test summary
override_dh_auto_clean:
touch config.h external.config.h
dh_auto_clean
rm -rf bin
debian/cpptraj.1:
help2man cpptraj --no-discard-stderr --no-info --name 'fast, parallelized molecular dynamics trajectory data analysis' > $@
|