1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83
|
.NOTPARALLEL:
package=crm114
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
CFLAGS += -DVERSION='\"\$$(VERSION)\"'
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
build: build-arch build-indep
build-arch: build-stamp
build-indep: build-stamp
build-stamp:
dh_testdir
dh_auto_build --parallel -- CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)"
touch build-stamp
clean:
dh_testdir
dh_testroot
rm -f build-stamp
$(MAKE) clean
dh_clean
debconf-updatepo
install: build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
$(MAKE) install prefix=`pwd`/debian/$(package)/usr
install shuffle.crm `pwd`/debian/$(package)/usr/share/crm114/
dh_installdebconf
# Build architecture-independent files here.
binary-indep: build install
# We have nothing to do by default.
# Build architecture-dependent files here.
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs
dh_install
dh_installdocs
rm `pwd`/debian/crm114/usr/share/doc/$(package)/GPL_License.txt
mv `pwd`/debian/crm114/usr/share/doc/$(package)/*test* \
`pwd`/debian/crm114/usr/share/doc/$(package)/examples/tests/
set -e; for ext in cf crm dat example mfp recipe; do \
mv `pwd`/debian/crm114/usr/share/doc/$(package)/*.$$ext \
`pwd`/debian/crm114/usr/share/doc/$(package)/examples/; \
done
dh_installexamples
set -e; for file in `pwd`/debian/crm114/usr/share/doc/$(package)/examples/* \
`pwd`/debian/crm114/usr/share/doc/$(package)/examples/tests/*; do \
if [ -f $$file ] && [ "`head -c 2 $$file`" != '#!' ]; then \
chmod a-x $$file; \
fi; \
done
chmod a-x `pwd`/debian/crm114/usr/share/crm114/mailfilter.cf
chmod a+x `pwd`/debian/crm114/usr/share/crm114/*.crm
chmod a-x `pwd`/debian/crm114/usr/share/crm114/maillib.crm
chmod a-x `pwd`/debian/crm114/usr/share/emacs/site-lisp/*
dh_installman debian/*.1
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install
|