File: changelog

package info (click to toggle)
cucumber 2.4.0-4
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 3,064 kB
  • sloc: ruby: 17,016; javascript: 4,641; makefile: 12; sh: 10; tcl: 3
file content (188 lines) | stat: -rw-r--r-- 6,655 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
cucumber (2.4.0-4) unstable; urgency=medium

  [ Cédric Boutillier ]
  * Skip failing tests with diff-lcs 1.4.1 (Closes: #968628, #966946)
  * Drop compat file, rely on debhelper-compat and bump compat level to 13
  * Update team name
  * Add .gitattributes to keep unwanted files out of the source package
  * Install examples
  * Avoid deduplicated files in examples with jdupes
  * Set explicitly that d/rules doesn't require root

  [ Utkarsh Gupta ]
  * Use salsa.debian.org in Vcs-* fields
  * Move debian/watch to gemwatch.debian.net
  * Fix section, url, watch file and rules

  [ Debian Janitor ]
  * Set upstream metadata fields: Bug-Database, Bug-Submit.
  * Update standards version to 4.5.0, no changes needed.

 -- Cédric Boutillier <boutil@debian.org>  Thu, 17 Sep 2020 11:11:47 +0200

cucumber (2.4.0-3) unstable; urgency=medium

  [ Antonio Terceiro ]
  * Remove myself from Uploaders

  [ Cédric Boutillier ]
  * Declare ruby autopkgtest Testsuite
  * Replace dpkg-parsechangelog by DEB_VERSION/SOURCE_DATE_EPOCH env variables
  * Add 0007_exclude_vendor_ruby_json.patch to exclude system cucumber files
    from backtrace and help autopkgtests pass
  * Bump Standards-Version to 4.1.1 (no changes needed)
  * Bump Debhelper compatibility level to 10

 -- Cédric Boutillier <boutil@debian.org>  Thu, 12 Oct 2017 22:07:21 +0200

cucumber (2.4.0-2) unstable; urgency=medium

  * Add 0006_fix_formatter_html_spec.patch from upstream to fix bug in specs
    with HTML formatters (Closes: #839910)

 -- Cédric Boutillier <boutil@debian.org>  Fri, 07 Oct 2016 23:40:14 +0200

cucumber (2.4.0-1) unstable; urgency=medium

  [ Stefano Rivera ]
  * Team upload.
  * New upstream release.
  * Refresh patches.
  * Drop patch 0002-Remove-require-rubygems-statements, superseded upstream.
  * New dependency: ruby-cucumber-wire.
  * Bump ruby-gherkin dependency to >= 4.
  * Bump Standards-Version to 3.9.8, no changes needed.
  * Bump copyright years.
  * Bump ruby-cucumber-core dependency to >= 1.5.

  [ Cédric Boutillier ]
  * Bump debhelper compatibility level to 9
  * Remove version in the gem2deb build-dependency
  * Use https:// in Vcs-* fields
  * Run wrap-and-sort on packaging files

 -- Stefano Rivera <stefanor@debian.org>  Mon, 25 Jul 2016 11:16:06 -0700

cucumber (2.0.0-2) unstable; urgency=medium

  * Add 0005-clean_bin_cucumber.patch to prevent cucumber utility to try to
    load non-existing files. (Closes: #789585)

 -- Cédric Boutillier <boutil@debian.org>  Mon, 22 Jun 2015 14:15:05 +0200

cucumber (2.0.0-1) unstable; urgency=medium

  [ Antonio Terceiro ]
  * debian/cucumber.pod: fix typo in manpage (Closes: #767215)

  [ Cédric Boutillier ]
  * Imported Upstream version 2.0.0
  * rename the file in debian/missing-source to remove -min suffix, and make
    lintian happy
  * reproducibility: use last changelog date to build the manpage
  * update 0004-Update_default_binary_path.patch
  * drop 0001-Remove-rubygems-bundler-stuff-from-spec_helper.patch, not needed
    anymore
  * build-depend on pry
  * depend on ruby-cucumber-core

 -- Cédric Boutillier <boutil@debian.org>  Sat, 20 Jun 2015 16:52:32 +0200

cucumber (1.3.17-1) unstable; urgency=medium

  * Imported Upstream version 1.3.17
  * Refresh 0004-Update_default_binary_path.patch
  * Bump Standards-Version to 3.9.6 (no changes needed)
  * Remove superfluous paragraph in debian/copyright about a removed patch

 -- Cédric Boutillier <boutil@debian.org>  Wed, 24 Sep 2014 10:07:14 +0200

cucumber (1.3.16-1) unstable; urgency=medium

  * Imported Upstream version 1.3.16

 -- Cédric Boutillier <boutil@debian.org>  Wed, 13 Aug 2014 22:40:00 +0200

cucumber (1.3.15-1) unstable; urgency=medium

  [ Jérémy Bobbio ]
  * Add git-buildpackage configuration

  [ Cédric Boutillier ]
  * Imported Upstream version 1.3.15
  * Relax version dependency on ruby-gherkin
  * Bump Standards-Version to 3.9.5 (no changes needed)
  * (Build-)depend on ruby-multi-test
    + drop 0005-Integrate-multi_test-code.patch
  * Refresh 0004-Update_default_binary_path.patch
  * Move source of jquery to debian/missing-sources

 -- Cédric Boutillier <boutil@debian.org>  Wed, 14 May 2014 22:26:02 +0200

cucumber (1.3.8-1) unstable; urgency=low

  * Imported Upstream version 1.3.8
  * debian/patches:
    + refresh 0004-Update_default_binary_path.patch
    + drop 0003-Disable-tests-assuming-ordered-hashes.patch, fixed upstream
  * increase minimal version of ruby-gherkin in dependencies

 -- Cédric Boutillier <boutil@debian.org>  Wed, 02 Oct 2013 14:49:19 +0200

cucumber (1.3.6-1) unstable; urgency=low

  * Imported Upstream version 1.3.6
  * debian/control:
    + remove obsolete DM-Upload-Allowed flag
    + use canonical URI in Vcs-* fields
    + remove duplicate rake in Build-Depends,
    + depend/build-depend on ruby-gherkin >= 2.12 and ruby-multi-json
    + update my email address
    + Bump Standards-Version to 3.9.4 (no changes needed)
  * debian/patches:
    + refresh 000{1,3}-*.patch
    + add 0004-Update_default_binary_path.patch:
      fix paths in cucumber/platform.rb. Thanks Kevin Locke (Closes: #681844)
    + add 0005-Integrate-multi_test-code.patch:
      include code of the multi_test gem

 -- Cédric Boutillier <boutil@debian.org>  Sat, 10 Aug 2013 23:37:41 +0200

cucumber (1.2.1-2) unstable; urgency=low

  * Explicitly depend on ruby-gherkin >= 2.11.0~

 -- Antonio Terceiro <terceiro@debian.org>  Tue, 26 Jun 2012 07:42:09 -0300

cucumber (1.2.1-1) unstable; urgency=low

  * New upstream version
  * Use ruby-test.rake to run tests. Build-depend on rake.
  * Bump Standards-Version: to 3.9.3 (no changes needed)
  * Add 003-Disable-tests-assuming-ordered-hashes.patch
    + disable tests relying on ordered hashes
  * Add myself to Uploaders:
  * Depend on libjs-jquery instead of using the embedded copy.
    + include non-minified copy of jquery as source of the embedded version
    + update copyright file to take into account jsquery
  * Do no suggest anymore ruby-prawn
  * Bump dependency of gem2deb to version >= 0.3.0

 -- Cédric Boutillier <cedric.boutillier@gmail.com>  Fri, 22 Jun 2012 01:02:55 +0200

cucumber (1.0.2-2) unstable; urgency=low

  [ Cédric Boutillier ]
  * copyright: change to a working url in Format: field

  [ Antonio Terceiro ]
  * Build-Depend on a newer gem2deb to make sure shebangs are correct
  * Make debian/copyright use a valid DEP-5 syntax

 -- Antonio Terceiro <terceiro@debian.org>  Fri, 02 Dec 2011 15:42:15 -0200

cucumber (1.0.2-1) unstable; urgency=low

  * Initial release (Closes: #636792)

 -- Antonio Terceiro <terceiro@debian.org>  Sun, 14 Aug 2011 13:49:11 -0700