1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27
|
DH_VERBOSE := 1
export PYBUILD_NAME=cwltool
export PYBUILD_DISABLE=test
export HOME=$(shell echo $$PWD"/fakehome")
%:
dh $@ --with python2 --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
debian/cwltool.1: debian/rules debian/cwltool.help2man
python2 setup.py develop --user
help2man 'python -m cwltool' -I debian/cwltool.help2man -N -o debian/cwltool.1
override_dh_installman: debian/cwltool.1
dh_installman
override_dh_clean:
dh_clean
rm -f debian/cwltool.1
|