File: changelog

package info (click to toggle)
daq 2.0.4-3
  • links: PTS
  • area: main
  • in suites: bullseye, buster, sid, stretch
  • size: 2,328 kB
  • sloc: ansic: 14,009; sh: 11,159; yacc: 596; lex: 458; makefile: 156
file content (76 lines) | stat: -rw-r--r-- 3,202 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
daq (2.0.4-3) unstable; urgency=high

  * debian/control:
     - Fix typo in that made libdaq-dev depend on the previous libdaq0 instead
       of libdaq2
     - libdaq2 cannot be installed alongside libdaq0 (they both provide
       /usr/lib/libsfbpf.so.0.0.1), added a Conflicts: to reflect this

 -- Javier Fernández-Sanguino Peña <jfs@debian.org>  Sat, 25 Oct 2014 10:11:41 +0200

daq (2.0.4-2) unstable; urgency=medium

  * debian/control: Rename libdaq0 to libdaq2
    Also rename libdaq0.dirs -> libdaq2.dirs,
    libdaq0.install -> libdaq2.install
  * debian/libdaq-dev.install: Remove .la files

 -- Javier Fernández-Sanguino Peña <jfs@debian.org>  Fri, 24 Oct 2014 23:25:38 +0200

daq (2.0.4-1) unstable; urgency=medium

  * Upload the latest upstream release 
  * debian/rules:  
     - Use dh-autoreconf to get new libtool macros for ppc64el and update
       config.{sub,guess} for new arches. (Closes: 727353)
  * debian/control:
     - Use UTF-8 for maintainer's name
     - Update the Homepage to its current location
     - Update Standards version, no changes required
     - Use dh-autoreconf as suggested by Matthias Klose

 -- Javier Fernández-Sanguino Peña <jfs@debian.org>  Fri, 24 Oct 2014 23:17:25 +0200

daq (0.6.2-2) unstable; urgency=low

  * Upload to unstable (Closes: #656289)

 -- Javier Fernandez-Sanguino Pen~a <jfs@debian.org>  Wed, 18 Jan 2012 19:34:45 +0100

daq (0.6.2-1) experimental; urgency=low

  * New upstream release

 -- Andrew Pollock <apollock@google.com>  Thu, 22 Dec 2011 10:21:09 -0800

daq (0.3-2) experimental; urgency=low

  * Fix FTBFS: update Build-Depends with flex, bison (Closes: #609054)
  * This version now supports inline mode since the dumbnet library is now properly 
    detected (Closes: #609865)
  * To fix the above change the debian/patches/10_dnet-to-dumbnet.diff patch
    New changes in the patch:
      - Make m4/sf.m4 work with latest autoconf since the AX_CFLAGS_GCC_OPTION
        call would not work when using multiple GCC_OPTIONS, only one option (pedantic)
        is now check to set 
     - os-daq-modules/Makefile.am, os-daq-modules/daq_ipq.c, os-daq-modules/daq_nfq.c:
        Modified to use 'dumbnet' instead of 'dnet'
     - README: it's 'aclocal -I m4', there is no 'config' directory
     - More changes due to the automatic regeneration of all autoconf files after doing the
       above changes and running:
       'libbtoolize --copy --force ; aclocal -I m4; autoheader; autoconf; automake --foreign '

 -- Javier Fernandez-Sanguino Pen~a <jfs@debian.org>  Thu, 13 Jan 2011 01:11:14 +0100

daq (0.3-1) experimental; urgency=low

  * Initial release. 
  * This library is required for Snort 2.9.0 (produced by the Snort team).
    Since I will be targetting experimental with Snort 2.9.0 I'm uploading this
    library there too.
  * debian/patches/10_dnet-to-dumbnet.diff: Patch to use dumbnet instead of
    dnet. It is not applied as it currently breaks the build due to an autoconf
    issue (to be investigated). This only prevents the IPQ and NFQ DAQs from
    being available (but the PCAP module should work)

 -- Javier Fernandez-Sanguino Pen~a <jfs@debian.org>  Thu, 11 Nov 2010 00:52:20 +0100