File: changelog

package info (click to toggle)
datalad 0.4.1-1
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 4,076 kB
  • sloc: python: 29,937; sh: 491; makefile: 210
file content (103 lines) | stat: -rw-r--r-- 3,317 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
datalad (0.4.1-1) unstable; urgency=medium

  * New upstream release
  * debian/control
    - require python-git >| 2.1~, and python-github

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 10 Nov 2016 15:14:24 -0500

datalad (0.4-1) unstable; urgency=medium

  * New upstream release
  * debian/control
    - add python-secretstorage into build-depends for keyring >= 9.2

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 21 Oct 2016 21:19:47 -0400

datalad (0.3.1-1) unstable; urgency=medium

  * Fresh upstream bugfix/minor release

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 01 Oct 2016 15:06:47 -0400

datalad (0.3-1) unstable; urgency=medium

  * New upstream release
    - should resolve FTBFS due to incompatibilities with new git version
      (Closes: #835525)
  * Install bash completions under /usr/share/bash-completion/completions
    (TODO: deploy them for zsh)
  * debian/copyright - updated to reflect added components

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 23 Sep 2016 09:22:01 -0400

datalad (0.2.3+git843-g18c597d-1) UNRELEASED; urgency=medium

  * New upstream snapshot from 0.2.3-843-g18c597d
  * debian/control
    - new build-depends and depends/recommends:
      python-{pyld,requests,simplejson,iso8601,jsmin,requests-ftp,yaml}
    - testtools removed from *depends - not used ATM

 -- Yaroslav Halchenko <debian@onerussian.com>  Sat, 10 Sep 2016 13:35:04 -0400

datalad (0.2.3-1) unstable; urgency=medium

  * Fresh upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Tue, 28 Jun 2016 01:04:10 +0200

datalad (0.2.2-1) unstable; urgency=medium

  * Fresh upstream release

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 20 Jun 2016 17:47:16 -0400

datalad (0.2.1-2) neurodebian; urgency=medium

  * Skip testing components which require recent scrapy

 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 13 Jun 2016 11:12:30 -0400

datalad (0.2.1-1) unstable; urgency=medium

  * New bugfix + enhancements upstream release
  * patch refreshed
  * python-tqdm into *Depends as a preference over progressbar

 -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 10 Jun 2016 21:43:53 -0400

datalad (0.2-1) unstable; urgency=medium

  * New upstream release, with complete refactoring of the "distribution"
    component.

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 19 May 2016 15:29:08 -0400

datalad (0.1+git589-g4f196dc-1) neurodebian-devel; urgency=medium

  * New upstream snapshot from 0.1-573-gec0b018
  * debian/control
    - adjusted build/depends (bunch of new ones, no need for joblib atm)
  * debian/control
    - dance around git config email/name

 -- Yaroslav Halchenko <debian@onerussian.com>  Thu, 25 Feb 2016 22:29:38 -0500

datalad (0.1-1) neurodebian-devel; urgency=medium

  * Fresh upstream release with a sketch of publishing functionality

 -- Yaroslav Halchenko <debian@onerussian.com>  Wed, 14 Oct 2015 22:21:42 -0400

datalad (0.0.4-1) neurodebian-devel; urgency=low

  [ Yaroslav Halchenko ]
  * Initial Debian packaging

  [ Michael Hanke ]
  * Add lintian override for insufficient dependencies of the 'datalad'
    package. All relevant dependencies are satisfied by the tightly coupled
    'python-datalad' package.

 -- Yaroslav Halchenko <debian@onerussian.com>  Sun, 27 Sep 2015 10:57:58 -0400