1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
export PERL5LIB=.
%:
dh $@ --with python2,python3
override_dh_auto_install:
$(MAKE) prefix=`pwd`/debian/debconf-utils install-utils
$(MAKE) prefix=`pwd`/debian/debconf-i18n install-i18n
$(MAKE) prefix=`pwd`/debian/python-debconf install-python2
$(MAKE) prefix=`pwd`/debian/python3-debconf install-python3
$(MAKE) prefix=`pwd`/debian/debconf install-rest
override_dh_installdocs:
dh_installdocs -Ndebconf-doc --link-doc=debconf
dh_installdocs -pdebconf-doc
override_dh_installdebconf:
dh_installdebconf -n
override_dh_installchangelogs:
perl -ne '$$c++ if /^debconf /; last if $$c > 100 ; print $$_' \
< debian/changelog > debian/debconf.changelog
dh_installchangelogs
override_dh_compress:
dh_compress -X demo.templates -X tutorial.templates
|