1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
|
#!/bin/sh
set -e
if [ "$1" = 'configure' -a -n "$2" ]; then
if dpkg --compare-versions "$2" 'lt' "2012.1" && which gpg > /dev/null && which apt-key > /dev/null; then
TRUSTEDFILE='/etc/apt/trusted.gpg'
eval $(apt-config shell TRUSTEDFILE Apt::GPGV::TrustedKeyring)
eval $(apt-config shell TRUSTEDFILE Dir::Etc::Trusted/f)
if [ -e "$TRUSTEDFILE" ]; then
for KEY in F42584E6 55BE302B 6D849617 B98321F9 473041FA 46925553 65FFB764; do
apt-key --keyring "$TRUSTEDFILE" del $KEY > /dev/null 2>&1 || :
done
fi
fi
fi
|