1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64
|
tex := tex
out := derivations
configure : configure-stamp
configure-stamp :
dh_testdir
@
touch configure-stamp
build : build-stamp
build-arch : build-stamp
build-indep : build-stamp
build-stamp : configure-stamp
dh_testdir
BUILD_FOR_PACKAGING=1 $(MAKE) $(tex)/$(out).ps $(tex)/$(out).pdf
@
touch build-stamp
clean :
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
$(MAKE) clean
@
dh_clean
install : build
dh_testdir
dh_testroot
dh_prep
dh_installdirs
@
binary-indep : build install
dh_testdir
dh_testroot
dh_installchangelogs doc/changelog
dh_installdocs
dh_installman
@
@
dh_link
dh_compress -X.pdf
dh_fixperms
dh_installdeb
dh_gencontrol
dh_md5sums
dh_builddeb
binary : binary-indep
binary-arch : ;
orig : ; dh_testdir ; bash - debian/mkorig
orig-force : ; dh_testdir ; bash - debian/mkorig -f
cleandeb-force : ; dh_testdir ; bash - debian/cleandeb -f
.PHONY: configure build clean install binary-indep binary \
orig orig-force cleandeb-force
|