File: changelog.txt

package info (click to toggle)
dh-make-drupal 2.1-2
  • links: PTS, VCS
  • area: main
  • in suites: stretch
  • size: 140 kB
  • ctags: 88
  • sloc: ruby: 835; makefile: 9
file content (113 lines) | stat: -rw-r--r-- 4,092 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
2.1 (2015-09-08)
* Hpricot is considered deprecated, so dh-make-drupal was ported over
  to Nokogiri. Things seem not to break - But bug reports are
  expected! :)

2.0 (2015-05-14)
* Fixed bug that caused an ugly error message instead of a proper one
  when no licensing information is found. Thanks to Adi Kriegisch for
  the fix!
* Upgraded generated Debian packages' standards-version to 3.9.6

1.9 (2015-03-28)
* Fixed bug in the version tables parsing; thanks to Matthew
  Gabeler-Lee for providing the fix!

1.8 (2014-05-13)
  * Updated generated standards-version to 3.9.5
  * Fix some deprecation warnings due to the update of the Ruby version
  * (Partially) fix the detection of "developer" versions as "recommended"
    ones. (Still breaks where no recommended versions are found)

1.7 (2013-11-25)
 * Drupal.org updated from 6.x to 7.x, screen scraping logic had to
   be updated
 * Thanks to Stefan Hornburg and Stefan Kangas for almost
   simultaneously reporting the issue!

1.6 (2013-08-01)
 * Fixed a problem with the 1.5 patch that errored out on modules not
   providing submodules
 * Minor correctness/reliability fixes

1.5 (2013-06-25)
 * Included patch by Pauli allowing user to specify the provided
   submodules

1.4 (2013-06-03)
 * Again, thanks to Stefan Kangas
   (https://github.com/gwolf/dh-make-drupal/pull/3)
 * Drupal.org now requires requests to go over https

1.3 (2013-02-18)
 * Thanks to Stefan Kangas - This release is basically a pull request
   of his work (https://github.com/gwolf/dh-make-drupal/pull/2)
 * Provide a User-Agent to keep working despite drupal.org's new
   restrictions
 * Show the OpenURI::HTTPError exception reasons
 * Fix the generated Build-Depends to work correctly on Squeeze

1.2 (2012-08-13)
 * "Switch '-d' (Drupal version) was not accepting its needed argument.
   Fixed, thanks  to Matthew Gabeler-Lee for the report

1.1 (2012-06-28)
 * Fix a syntactic detail with optparse: The mandatory arguments for
   some options were not correctly declared, so the program didn't
   know what to do with them

1.0 (2012-06-15)
 * Use optparse (part of the Ruby standard library) instead of the
   (orphaned and Ruby 1.9-incompatible) CommandLine::Application
 * Default to Drupal 7 instead of 6
 * Protect some OpenURI calls avoiding ugly OpenURI::HTTPError
   exceptions

0.9 (2012-03-09)
 * Add the modules list for Drupal7
 * Updated the packaging style/compat level to debhelper 8, which led
   to some minor reorganizations

0.8 (2010-10-23)
 * Rework HPricot logic to cope with drupal.org's site reorganization
 * State that translation support is currently less-than-stellar :-(
   It should be brought back to level once the Debian release is
   done.

0.7 (2010-08-25)
 * Avoid dying with an exception if LICENSE.txt does not exist (thanks
   to Roel de Cock for the report)
 * No longer chokes on needlesly quoted dependencies
 * Updated generated standards-version to 3.9.1.0

0.6 - 2010-04-15
 * Updated generated standards-version to 3.8.4
 * Builds a list of recommended modules/packages out of the
   submodules' *.info files (Debian bug #557116)
 * Now builds packages using the «3.0 (quilt)» source format

0.5 - 2009-12-24
 * Drupal.org page layout changed - The present changes made it work
   again :)

0.4 - 2009-06-26
 * Use the Debian email/fullname environment variables if they are
   found
 * Properly mangles -dev, -alpha, -beta, -rc version numbers with "~"
   character (double ~ for -dev) to properly sort them on Debian
 * Fixed bug which caused packages whose names include underscores to
   be built as debian-native packages

0.3 - 2009-02-27
 * Added dependency parsing/declaration for modules
 * Options are now handled through the DrupalProject::Options class,
   allowing for a cleaner flow and separation of concerns
 * Can also now start from a local tarball, no longer needs to fetch
   data from the Drupal website

0.2 - 2009-02-19
 * Updated release fetching code, due to a new webpage layout
 * Added the needed logic to also package translations

0.1 - 2009-02-16
 * Initial release