1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235
|
Description: Switch tooo new PCRE2
Bug-Debian: https://bugs.debian.org/1000086
Bug: https://puszcza.gnu.org.ua/bugs/index.php?600
Origin:https://git.gnu.org.ua/dico.git/patch/?id=ef0eb6cc0afc70b381ff
@@ -19,7 +19,7 @@
mod_LTLIBRARIES=pcre.la
pcre_la_SOURCES = pcre.c
-pcre_la_LIBADD = ../../lib/libdico.la -lpcre
+pcre_la_LIBADD = ../../lib/libdico.la -lpcre2-8
AM_LDFLAGS = -module -avoid-version -no-undefined
AM_CPPFLAGS = @DICO_MODULE_INCLUDES@
EXTRA_DIST=module.ac
@@ -27,9 +27,9 @@
esac],[status_pcre=yes])
if test $status_pcre = yes; then
- AC_CHECK_HEADER([pcre.h], [], [status_pcre=no])
+ AC_CHECK_HEADER([pcre2.h], [], [status_pcre=no], [#define PCRE2_CODE_UNIT_WIDTH 8])
if test $status_pcre = yes; then
- DICO_CHECK_LIB(pcre, main, [],
+ DICO_CHECK_LIB(pcre2-8, main, [],
[:],
[status_pcre=no])
fi
@@ -20,7 +20,8 @@
#include <ctype.h>
#include <errno.h>
#include <appi18n.h>
-#include <pcre.h>
+#define PCRE2_CODE_UNIT_WIDTH 8
+#include <pcre2.h>
struct dico_pcre_flag
{
@@ -29,15 +30,15 @@
};
static struct dico_pcre_flag flagtab[] = {
- { 'a', PCRE_ANCHORED }, /* Force pattern anchoring */
- { 'e', PCRE_EXTENDED }, /* Ignore whitespace and # comments */
- { 'i', PCRE_CASELESS }, /* Do caseless matching */
- { 'G', PCRE_UNGREEDY }, /* Invert greediness of quantifiers */
+ { 'a', PCRE2_ANCHORED }, /* Force pattern anchoring */
+ { 'e', PCRE2_EXTENDED }, /* Ignore whitespace and # comments */
+ { 'i', PCRE2_CASELESS }, /* Do caseless matching */
+ { 'G', PCRE2_UNGREEDY }, /* Invert greediness of quantifiers */
{ 0 },
};
static int
-pcre_flag(int c, int *pflags)
+pcre_flag(int c, uint32_t *pflags)
{
struct dico_pcre_flag *p;
@@ -53,75 +54,103 @@
return 1;
}
-static pcre *
+static pcre2_code *
compile_pattern(const char *pattern)
{
- int cflags = PCRE_UTF8|PCRE_NEWLINE_ANY;
- const char *error;
- int error_offset;
- char *tmp = NULL;
- pcre *pre;
+ uint32_t cflags = PCRE2_UTF|PCRE2_NEWLINE_ANY;
+ int error;
+ PCRE2_SIZE length;
+ PCRE2_SIZE error_offset;
+ pcre2_code *pre;
+ /*
+ * Pcre2 documentation claims that pattern length is measured in code
+ * points. This, however, doesn't seem to be the case. At least, with
+ * version 10.35, length is measured in characters.
+ */
+ length = strlen(pattern);
if (pattern[0] == '/') {
- size_t len;
- char *p;
+ char *p;
- pattern++;
- p = strrchr(pattern, '/');
- if (!p) {
- dico_log(L_ERR, 0, _("PCRE missing terminating /: %s"),
- pattern - 1);
- return NULL;
- }
- len = p - pattern;
-
- while (*++p) {
- if (pcre_flag(*p, &cflags)) {
- dico_log(L_ERR, 0, _("PCRE error: invalid flag %c"), *p);
- return NULL;
- }
- }
-
- tmp = malloc(len + 1);
- if (!tmp)
- return NULL;
- memcpy(tmp, pattern, len);
- tmp[len] = 0;
- pattern = tmp;
+ pattern++;
+ length--;
+ p = strrchr(pattern, '/');
+ if (!p) {
+ dico_log(L_ERR, 0, _("PCRE missing terminating /: %s"),
+ pattern - 1);
+ return NULL;
+ }
+ length -= strlen(p);
+
+ while (*++p) {
+ if (pcre_flag(*p, &cflags)) {
+ dico_log(L_ERR, 0, _("PCRE error: invalid flag %c"), *p);
+ return NULL;
+ }
+ }
}
- pre = pcre_compile(pattern, cflags, &error, &error_offset, 0);
+ pre = pcre2_compile((PCRE2_SPTR8)pattern, length, cflags, &error, &error_offset, NULL);
if (!pre) {
- dico_log(L_ERR, 0,
- _("pcre_compile(\"%s\") failed at offset %d: %s"),
- pattern, error_offset, error);
+ char errbuf[120];
+
+ switch (pcre2_get_error_message(error, (PCRE2_UCHAR8*)errbuf, sizeof errbuf)) {
+ case PCRE2_ERROR_NOMEMORY:
+ default:
+ break;
+ case PCRE2_ERROR_BADDATA:
+ strncpy(errbuf, "bad error code", sizeof(errbuf)-1);
+ break;
+ }
+ dico_log(L_ERR, 0,
+ _("pcre_compile(\"%s\") failed at offset %lu: %s"),
+ pattern, error_offset, errbuf);
}
- free(tmp);
return pre;
}
+struct pcre_call_data
+{
+ pcre2_code *code;
+ pcre2_match_data *md;
+};
+
static int
pcre_sel(int cmd, dico_key_t key, const char *dict_word)
{
int rc = 0;
char const *word = key->word;
- pcre *pre = key->call_data;
+ struct pcre_call_data *cdata = key->call_data;
switch (cmd) {
case DICO_SELECT_BEGIN:
- pre = compile_pattern(word);
- if (!pre)
- return 1;
- key->call_data = pre;
- break;
+ if ((cdata = calloc(1, sizeof(cdata[0]))) == NULL) {
+ DICO_LOG_MEMERR();
+ return 1;
+ }
+ if ((cdata->code = compile_pattern(word)) == NULL) {
+ free(cdata);
+ return 1;
+ }
+ cdata->md = pcre2_match_data_create_from_pattern(cdata->code, NULL);
+ if (cdata->md == NULL) {
+ pcre2_code_free(cdata->code);
+ free(cdata);
+ return 1;
+ }
+ key->call_data = cdata;
+ break;
case DICO_SELECT_RUN:
- rc = pcre_exec(pre, 0, dict_word, strlen(dict_word), 0, 0,
- NULL, 0) >= 0;
- break;
-
+ rc = pcre2_match(cdata->code,
+ (PCRE2_SPTR8)dict_word, PCRE2_ZERO_TERMINATED,
+ 0, 0, cdata->md, NULL) >= 0;
+ break;
+
case DICO_SELECT_END:
- pcre_free(pre);
- break;
+ pcre2_match_data_free(cdata->md);
+ pcre2_code_free(cdata->code);
+ free(cdata);
+ break;
}
return rc;
}
@@ -395,9 +395,9 @@
esac],[status_pcre=yes])
if test $status_pcre = yes; then
- AC_CHECK_HEADER([pcre.h], [], [status_pcre=no])
+ AC_CHECK_HEADER([pcre2.h], [], [status_pcre=no], [#define PCRE2_CODE_UNIT_WIDTH 8])
if test $status_pcre = yes; then
- DICO_CHECK_LIB(pcre, main, [],
+ DICO_CHECK_LIB(pcre2-8, main, [],
[:],
[status_pcre=no])
fi
|