1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134
|
Author: Andreas Tille <tille@debian.org>
Last-Update: Mon, 21 Jan 2019 09:01:19 +0100
Description: Use cmake input file of Debian packaged gatb-core
@@ -32,8 +32,8 @@
################################################################################
# Define cmake modules directory
################################################################################
-SET (GATB_CORE_HOME ${PROJECT_SOURCE_DIR}/thirdparty/gatb-core/gatb-core)
-SET (CMAKE_MODULE_PATH ${GATB_CORE_HOME}/cmake)
+include(GNUInstallDirs)
+SET (CMAKE_MODULE_PATH /usr/${CMAKE_INSTALL_LIBDIR}/cmake)
################################################################################
# THIRD PARTIES
@@ -43,9 +43,6 @@
SET (GATB_CORE_EXCLUDE_TESTS 1)
SET (GATB_CORE_EXCLUDE_EXAMPLES 1)
-# GATB CORE
-include (GatbCore)
-
################################################################################
# TOOLS GENERATION
################################################################################
@@ -16,13 +16,15 @@
file (GLOB_RECURSE ProjectFiles src/*)
# we define the artifact to be built: the project binary
+include(GNUInstallDirs)
+LINK_DIRECTORIES( /usr/${CMAKE_INSTALL_LIBDIR}/hdf5/serial )
add_executable (${PROJECT_NAME} ${ProjectFiles})
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIRZ})
# we define which libraries to be linked with project binary
-target_link_libraries (${PROJECT_NAME} ${gatb-core-libraries})
+target_link_libraries (${PROJECT_NAME} gatbcore hdf5 z )
# We copy the project binary to the 'bin' directory
@@ -16,14 +16,16 @@
file (GLOB_RECURSE ProjectFiles src/*)
# we define the artifact to be built: the project binary
+include(GNUInstallDirs)
+LINK_DIRECTORIES( /usr/${CMAKE_INSTALL_LIBDIR}/hdf5/serial )
add_executable (${PROJECT_NAME} ${ProjectFiles})
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIRZ})
# we define which libraries to be linked with project binary
-target_link_libraries (${PROJECT_NAME} ${gatb-core-libraries})
+target_link_libraries (${PROJECT_NAME} gatbcore hdf5 z )
# We copy the project binary to the 'bin' directory
-INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
\ No newline at end of file
+INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
@@ -16,14 +16,16 @@
file (GLOB_RECURSE ProjectFiles src/*)
# we define the artifact to be built: the project binary
+include(GNUInstallDirs)
+LINK_DIRECTORIES( /usr/${CMAKE_INSTALL_LIBDIR}/hdf5/serial )
add_executable (${PROJECT_NAME} ${ProjectFiles})
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIRZ})
# we define which libraries to be linked with project binary
-target_link_libraries (${PROJECT_NAME} ${gatb-core-libraries})
+target_link_libraries (${PROJECT_NAME} gatbcore hdf5 z )
# We copy the project binary to the 'bin' directory
-INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
\ No newline at end of file
+INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
@@ -16,14 +16,16 @@
file (GLOB_RECURSE ProjectFiles src/*)
# we define the artifact to be built: the project binary
+include(GNUInstallDirs)
+LINK_DIRECTORIES( /usr/${CMAKE_INSTALL_LIBDIR}/hdf5/serial )
add_executable (${PROJECT_NAME} ${ProjectFiles})
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIRZ})
# we define which libraries to be linked with project binary
-target_link_libraries (${PROJECT_NAME} ${gatb-core-libraries})
+target_link_libraries (${PROJECT_NAME} gatbcore hdf5 z )
# We copy the project binary to the 'bin' directory
-INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
\ No newline at end of file
+INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
@@ -16,14 +16,16 @@
file (GLOB_RECURSE ProjectFiles src/*)
# we define the artifact to be built: the project binary
+include(GNUInstallDirs)
+LINK_DIRECTORIES( /usr/${CMAKE_INSTALL_LIBDIR}/hdf5/serial )
add_executable (${PROJECT_NAME} ${ProjectFiles})
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIRZ})
# we define which libraries to be linked with project binary
-target_link_libraries (${PROJECT_NAME} ${gatb-core-libraries})
+target_link_libraries (${PROJECT_NAME} gatbcore hdf5 z )
# We copy the project binary to the 'bin' directory
-INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
\ No newline at end of file
+INSTALL (TARGETS ${PROJECT_NAME} DESTINATION bin)
|