1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26
|
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=django-auth-ldap
export PYBUILD_BEFORE_TEST=cp -r {dir}/tests {build_dir}
export PYBUILD_AFTER_TEST=rm -rf {build_dir}/tests
%:
dh $@ --with=python2,python3,sphinxdoc --buildsystem=pybuild
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. python3 -m sphinx -b html -N docs/ $(CURDIR)/debian/python-django-auth-ldap-doc/usr/share/doc/python-django-auth-ldap-doc/html
dh_sphinxdoc
endif
override_dh_auto_test:
dh_auto_test -- --system=custom --test-args="PYTHONPATH=. {interpreter} /usr/bin/django-admin test --settings tests.settings"
override_dh_clean:
rm -rf docs/.build/
dh_clean
|