1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74
|
Source: django-polymorphic
Section: python
Priority: optional
Maintainer: Debian Python Team <team+python@tracker.debian.org>
Uploaders:
Michael Fladischer <fladi@debian.org>,
Build-Depends:
debhelper-compat (= 13),
dh-python,
python3-all,
python3-django,
python3-django-extra-views,
python3-setuptools,
python3-sphinx,
python3-sphinx-rtd-theme,
Standards-Version: 4.5.0
Homepage: https://github.com/django-polymorphic/django-polymorphic
Vcs-Git: https://salsa.debian.org/python-team/packages/django-polymorphic.git
Vcs-Browser: https://salsa.debian.org/python-team/packages/django-polymorphic
Testsuite: autopkgtest-pkg-python
Rules-Requires-Root: no
Package: python-django-polymorphic-doc
Section: doc
Architecture: all
Depends:
${misc:Depends},
${sphinxdoc:Depends},
Description: Seamless Polymorphic Inheritance for Django Models (Documentation)
Django-polymorphic simplifies using inherited models in Django projects. When a
query is made at the base model, the inherited model classes are returned.
.
Features:
* Full admin integration.
* ORM integration:
+ Support for ForeignKey, ManyToManyField, OneToOneField descriptors.
+ Support for proxy models.
+ Filtering/ordering of inherited models (ArtProject___artist).
+ Filtering model types: instance_of(...) and not_instance_of(...)
+ Combining querysets of different models (qs3 = qs1 | qs2)
+ Support for custom user-defined managers.
* Uses the minimum amount of queries needed to fetch the inherited models.
* Disabling polymorphic behavior when needed.
.
This package contains the documentation.
Package: python3-django-polymorphic
Architecture: all
Depends:
python3-django,
python3-pkg-resources,
${misc:Depends},
${python3:Depends},
Recommends:
python3-django-extra-views,
Suggests:
python-django-polymorphic-doc,
Description: Seamless Polymorphic Inheritance for Django Models (Python3 version)
Django-polymorphic simplifies using inherited models in Django projects. When a
query is made at the base model, the inherited model classes are returned.
.
Features:
* Full admin integration.
* ORM integration:
+ Support for ForeignKey, ManyToManyField, OneToOneField descriptors.
+ Support for proxy models.
+ Filtering/ordering of inherited models (ArtProject___artist).
+ Filtering model types: instance_of(...) and not_instance_of(...)
+ Combining querysets of different models (qs3 = qs1 | qs2)
+ Support for custom user-defined managers.
* Uses the minimum amount of queries needed to fetch the inherited models.
* Disabling polymorphic behavior when needed.
.
This package contains the Python 3 version of the library.
|