1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33
|
include /usr/share/dpkg/pkg-info.mk
export PYBUILD_NAME=django-recurrence
export PYBUILD_AFTER_TEST=rm -f {build_dir}/.coverage {build_dir}/coverage.xml
%:
dh $@ --with python3,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
set -e; \
for loc in recurrence/locale/*; do \
python3 setup.py compile_catalog --directory recurrence/locale/ --locale $$(basename $$loc) --domain django; \
python3 setup.py compile_catalog --directory recurrence/locale/ --locale $$(basename $$loc) --domain djangojs; \
done
dh_auto_build
override_dh_sphinxdoc:
ifeq (,$(findstring nodoc, $(DEB_BUILD_OPTIONS)))
PYTHONPATH=. python3 -m sphinx -b html -N docs/ $(CURDIR)/debian/python-django-recurrence-doc/usr/share/doc/python-django-recurrence-doc/html
dh_sphinxdoc
endif
override_dh_clean:
rm -rf docs/.build
dh_clean
override_dh_compress:
dh_compress -X changelog.html
|