File: changelog

package info (click to toggle)
dnssec-trigger 0.17+repack-3
  • links: PTS, VCS
  • area: main
  • in suites: buster, sid
  • size: 2,896 kB
  • sloc: ansic: 18,697; sh: 977; makefile: 494; xml: 444; objc: 421; cpp: 18
file content (205 lines) | stat: -rw-r--r-- 7,534 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
dnssec-trigger (0.17+repack-3) unstable; urgency=medium

  * Remove add-null-to-end-of-string-list.patch upstream had better solution
  * Add dnssec-double-free.patch (Closes: 921227)
  * Update tests/small-key to test if small keys are fixed on upgrade
  * Modify remove-small-keys.patch to only generate the certificates if they don't exist
    (Closes: #919256)
  * Always run dnssec-trigger-control-setup to make sure that keys are updated

 -- Diane Trout <diane@ghic.org>  Wed, 06 Feb 2019 21:29:17 -0800

dnssec-trigger (0.17+repack-2) unstable; urgency=medium

  * Test that we only create files in /etc/dnssec-trigger
  * Rename run-dhcp-test to test-install-paths
  * Use keydir macro to fix installation location of configuration files
  * fix dont-delete-unknown-names.patch
  * Fix url, we shouldn't point to the edit page for a bug forward
  * Add add-null-to-end-of-string-list.patch (Closes: 919256)

 -- Diane Trout <diane@ghic.org>  Tue, 15 Jan 2019 21:47:08 -0800

dnssec-trigger (0.17+repack-1) unstable; urgency=medium

  * New upstream release
  * Refresh patches
  * Remove 0001-dnssec-trigger-openssl-1.1.0-fixup.patch
  * Remove 0007-use-libnm.patch, resolved upstream
  * Delete some test artifacts that weren't being cleaned
  * Refresh reproducible-build.patch
  * Enable with-forward-zones-support
  * Add build and install dependency on sensible-utils.
  * Add libcmocka-dev dependency, needed for some of upstreams test code
  * Require that libssl 1.1 is installed before we upgrade.
  * Regnerate control keys that are too small on startup (Closes: #898969)
  * Test to see if #779298 was fixed
  * Test that #898969 is fixed
  * Add patch dont-delete-unknown-names.patch
  * Update Standards-Versiong to 4.3.0. No changes needed
  * Change breaks: to conflicts: resolvconf

 -- Diane Trout <diane@ghic.org>  Sun, 13 Jan 2019 13:10:28 -0800

dnssec-trigger (0.15+repack-1) unstable; urgency=medium

  * Update Standards-Version to 4.1.4.
    - Update copyright url.
  * Add 0007-use-libnm.patch to port to libnm. (Closes: #862757)
  * Add reproducible-build.patch (Closes: #862757)
  * Update to secure VCS urls.
  * Ignore prebuilt visual studio files
  * Add dependency on lsb-base for init.d processing
  * Remove autoconf dependencies as they're provided by debhelper
  * Use Python 3 for trigger script
  * indicate we're repacking the source
  * Add missing variable subtititutions to
    0006-Unhardcode-most-of-the-paths.patch
  * Use secure url for homepage
  * debhelper 11 handles systemd installation automatically
  * Update to salsa VCS repository URLs
  * New upstream version 0.15+repack
  * Refresh openssl-1.1.0 compatibility patch
  * Update copyright file
  * Update maintainer to dnssec-trigger packages.debian.org

 -- Diane Trout <diane@ghic.org>  Mon, 14 May 2018 21:32:02 -0700

dnssec-trigger (0.13-4) unstable; urgency=high

  * Fix the missing systemdsystemunitdir variable assignment in
    Makefile.in (Closes: #852297)

 -- Ondřej Surý <ondrej@debian.org>  Tue, 31 Jan 2017 11:53:14 +0100

dnssec-trigger (0.13-3) unstable; urgency=medium

  * Update patches to be in sync with PR on upstream
    + OpenSSL 1.1.0
    + Unhardcoding most of the paths to favor ./configure options
  * Update debian/rules to match new configure options

 -- Ondřej Surý <ondrej@debian.org>  Thu, 22 Dec 2016 12:01:17 +0100

dnssec-trigger (0.13-2) unstable; urgency=medium

  * Add missing OpenSSL 1.1 compatibility parts (no SSL_OP_NO_SSLv2)
    (Closes: #849040)

 -- Ondřej Surý <ondrej@debian.org>  Thu, 22 Dec 2016 10:23:15 +0100

dnssec-trigger (0.13-1) unstable; urgency=medium

  * Imported Upstream version 0.13
  * Refresh patches on top of 0.13 release

 -- Ondřej Surý <ondrej@debian.org>  Tue, 20 Dec 2016 10:02:36 +0100

dnssec-trigger (0.13~svn685-7) unstable; urgency=medium

  [ Sebastian Andrzej Siewior ]
  * OpenSSL 1.1.0 fixup

 -- Ondřej Surý <ondrej@debian.org>  Tue, 08 Nov 2016 10:14:15 +0100

dnssec-trigger (0.13~svn685-6) unstable; urgency=medium

  [ Stuart Prescott ]
  * Tweak detection of OpenSSL to build with version 1.1 (Closes: #828283)

  [ Ondřej Surý ]
  * Move package under pkg-dns
  * Use gbp pq for patch management

 -- Ondřej Surý <ondrej@debian.org>  Sun, 06 Nov 2016 16:08:37 +0100

dnssec-trigger (0.13~svn685-5) unstable; urgency=medium

  * Add patch to support network-manager (>= 1.1.90) (Closes: #815880)

 -- Ondřej Surý <ondrej@debian.org>  Thu, 24 Mar 2016 23:11:07 +0100

dnssec-trigger (0.13~svn685-4) unstable; urgency=medium

  * Add Breaks: resolvconf because immutable flag on resolv.conf doesn't
    play well with resolvconf (Closes: #776776)

 -- Ondřej Surý <ondrej@debian.org>  Thu, 05 Feb 2015 09:36:36 +0100

dnssec-trigger (0.13~svn685-3) unstable; urgency=medium

  [Diane Trout]
  * Add dash_compatibility.patch to (Closes: #772262)

 -- Ondřej Surý <ondrej@debian.org>  Mon, 08 Dec 2014 13:26:48 +0100

dnssec-trigger (0.13~svn685-2) unstable; urgency=medium

  * Depend on gir1.2-networkmanager-1.0 only on linux-any

 -- Ondřej Surý <ondrej@debian.org>  Thu, 23 Oct 2014 11:53:16 +0200

dnssec-trigger (0.13~svn685-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Fix incorrect configure parameter name (Closes: #757320)
  * Add missing dependency on python-gi
  * Add missing dependency on gir1.2-networkmanager-1.0
  * Add missing dependency on python-lockfile (Closes: #758731)
  * Apply patch from Gerald Turner to fix paths in desktop file
    (Closes: #756149)
  * Add tmpfiles.d config file (Closes: #758729)

 -- Arto Jantunen <viiru@debian.org>  Thu, 25 Sep 2014 19:17:04 +0300

dnssec-trigger (0.13~svn685-1) unstable; urgency=medium

  * New upstream version 0.13~svn685 (Closes: #754853)

 -- Ondřej Surý <ondrej@debian.org>  Tue, 15 Jul 2014 12:25:13 +0200

dnssec-trigger (0.13~svn683-2) unstable; urgency=medium

  * Symlink manpages for all binaries to dnssec-trigger.8
  * Strip version number from installed config (Closes: #753673)
  * Delete all dnssec-trigger-{control,server} keys on purge

 -- Ondřej Surý <ondrej@debian.org>  Fri, 04 Jul 2014 10:40:17 +0200

dnssec-trigger (0.13~svn683-1) unstable; urgency=medium

  * New upstream snapshot version 0.13~svn683 with merged Debian patches
    (Closes: #753447, #753448, #753449)
  * Update patches on top of upstream subversion repository (r681)
  * Correctly set libexecdir to /usr/lib/dnssec-trigger to avoid patching
  * Use correct path (/lib/systemd) for systemd.service file
  * Enable full hardening (+all) and some extra CFLAGS and LDFLAGS
  * Fix various debian paths:
    + /etc -> /etc/dnssec-trigger
    + /var/run -> /run

 -- Ondřej Surý <ondrej@debian.org>  Thu, 03 Jul 2014 16:00:34 +0200

dnssec-trigger (0.12-2) unstable; urgency=high

  * Fix invalid location of pidof (Closes: #753318)

 -- Ondřej Surý <ondrej@debian.org>  Mon, 30 Jun 2014 20:33:09 +0200

dnssec-trigger (0.12-1) unstable; urgency=medium

  * Tighten build dependency on ldns 1.6.14-1~ to fixate on ldns
    version without strlcpy
  * New upstream version 0.12
  * Remove obsolete patches; merged upstream
  * d/control: Add dependency on python
  * d/control,d/rules: Add support for included systemd scripts
  * Rename sysvinit script to dnssec-triggerd to match systemd name

 -- Ondřej Surý <ondrej@debian.org>  Fri, 13 Jun 2014 14:45:51 +0200

dnssec-trigger (0.11-1) unstable; urgency=low

  * Initial release (Closes: #647096)

 -- Ondřej Surý <ondrej@debian.org>  Thu, 20 Feb 2014 10:58:08 +0100