File: .travis.yml

package info (click to toggle)
doit 0.31.1-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 1,504 kB
  • sloc: python: 10,835; makefile: 168; ansic: 14; sh: 4
file content (40 lines) | stat: -rw-r--r-- 762 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
language: python
python:
    - "3.4"
    - "3.5"
    - "3.6"
    # - "pypy3" pypy3 implements py3.2 not supported anymore

# when setting sudo to true, issues with strace are fixed
# see: https://github.com/travis-ci/travis-ci/issues/9033
sudo: true

addons:
  apt:
    packages:
      - strace

before_install:
  - pip install -U pip setuptools

install:
  - pip install .
  - pip install -r dev_requirements.txt python-coveralls

branches:
  only:
    - master
    - test


script:
   - doit pyflakes
   - py.test --ignore-flaky
   - if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then doit coverage; fi
after_success:
  - if [[ $TRAVIS_PYTHON_VERSION == '3.6' ]]; then coveralls; fi

notifications:
    email:
        on_success: change
        on_failure: change