File: appveyor.yml

package info (click to toggle)
doxygen 1.8.16-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 22,176 kB
  • sloc: cpp: 245,005; lex: 37,843; ansic: 14,229; xml: 12,168; python: 3,038; tcl: 594; yacc: 576; php: 446; perl: 370; makefile: 213; objc: 14; sh: 11; cs: 5; f90: 4; java: 1
file content (60 lines) | stat: -rw-r--r-- 1,864 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
image: Visual Studio 2017

configuration:
  - Release
  - Debug

platform:
  - x64
  - Win32

environment:
  # VS VERSION IN CMAKE STYLE
  matrix:
    - VSVERSION: "15 2017"
    - VSVERSION: "14 2015"

cache:
  - C:\Users\Appveyor\.conan -> appveyor.yml
  - c:\.conan -> appveyor.yml
  - '%LOCALAPPDATA%\pip\Cache -> appveyor.yml'
  - C:\miktex-repository -> appveyor.yml


init:
  - cmake --version
  - perl --version
  - msbuild /version

install:
  # Static url: https://github.com/MiKTeX/miktex/issues/321#issuecomment-496286866
  # The setup is small enough, and does not need to be cached
  - appveyor DownloadFile  https://miktex.org/download/win/miktexsetup-x64.zip
  - 7z e miktexsetup-x64.zip
  - miktexsetup.exe --local-package-repository=C:\miktex-repository --package-set=essential download
  - miktexsetup.exe --local-package-repository=C:\miktex-repository --package-set=essential --shared install
  - refreshenv
  - pip install conan
  - ps: |
     "[requires]
      libxml2/2.9.8@bincrafters/stable
      winflexbison/2.5.16@bincrafters/stable" | Out-File -Encoding ASCII -FilePath conanfile.txt
  - conan install . -g virtualrunenv --build missing
  - activate_run.bat

before_build:
  - if "%platform%"=="Win32" ( set "CMAKE_GENERATOR_NAME=Visual Studio %VSVERSION%" )
  - if "%platform%"=="x64" ( set "CMAKE_GENERATOR_NAME=Visual Studio %VSVERSION% Win64")
  - mkdir build
  - cd build
  - cmake -G "%CMAKE_GENERATOR_NAME%" ..

build:
  project: "build\\PACKAGE.vcxproj"
  parallel: false

test_script:
  - msbuild "testing\tests.vcxproj" /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"
# Disabled building document due to unreliable MikTeX installation
#  - cmake -G "%CMAKE_GENERATOR_NAME%" -D build_doc=ON ..
#  - msbuild "doc\docs.vcxproj" /logger:"C:\Program Files\AppVeyor\BuildAgent\Appveyor.MSBuildLogger.dll"