File: changelog

package info (click to toggle)
ebook-tools 0.2.2-4
  • links: PTS
  • area: main
  • in suites: bullseye, buster, jessie, jessie-kfreebsd, sid, stretch
  • size: 488 kB
  • ctags: 372
  • sloc: ansic: 2,953; sh: 63; makefile: 8
file content (129 lines) | stat: -rw-r--r-- 4,604 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
ebook-tools (0.2.2-4) unstable; urgency=medium

  [ Martin Pitt ]
  * Fix link order in "build" autopkgtest. (Closes: #756256)

 -- Pino Toscano <pino@debian.org>  Tue, 29 Jul 2014 21:07:32 +0200

ebook-tools (0.2.2-3) unstable; urgency=medium

  * Add a simple autopkgtest, loosely based on the patch provided by
    Vibhav Pant (thanks!): (Closes: #700911)
    + properly record the information on the epub test file used
    + add the XS-Testsuite: autopkgtest header.

 -- Pino Toscano <pino@debian.org>  Wed, 23 Jul 2014 20:44:57 +0200

ebook-tools (0.2.2-2) unstable; urgency=medium

  * Adapt FindLibZip.cmake to find zipconf.h also within the libdir; patch
    cmake_libzip_zipconf_path.diff. (Closes: #739152)
  * Bump Standards-Version to 3.9.5, no changes required.
  * Update packaging year in copyright.

 -- Pino Toscano <pino@debian.org>  Sun, 16 Feb 2014 11:23:21 +0100

ebook-tools (0.2.2-1) unstable; urgency=low

  * New upstream release.
  * Switch my email address to pino@debian.org.
  * Remove Vcs-* headers, the packaging there is not really up-to-date.
  * Remove obsolete DM-Upload-Allowed header.
  * Update packaging year in copyright.
  * Bump Standards-Version to 3.9.4, no changes required.
  * Bump debhelper compatibility to 9:
    + bump compat to 9
    + bump debhelper build dependency to >= 9
    + remove the custom link flags handling in rules
  * Enable parallel building.
  * Uniform "EPUB" in descriptions and manpages.
  * Link in as-needed mode.
  * Turn dh_install's --list-missing into --fail-missing.
  * Tighten the libepub0 dependency in epub-utils.

 -- Pino Toscano <pino@debian.org>  Fri, 28 Jun 2013 15:41:09 +0200

ebook-tools (0.2.1-2) unstable; urgency=low

  * Upload to unstable.
  * Bump packaging copyright year.

 -- Pino Toscano <pino@kde.org>  Mon, 07 Mar 2011 12:18:26 +0100

ebook-tools (0.2.1-1) experimental; urgency=low

  * New upstream release:
    + fixes crash on a file (Closes: #549686)
    + properly finds the TOC (Closes: #571649)
  * Remove patch 01_lit2epub_bashisms.diff:
    + fixed upstream
    + drop quilt build dependency (no more patches to apply)
  * Switch from CDBS to plain debhelper 7:
    + drop cdbs build dependency
    + bump debhelper build dependency to >= 7.0.50~
    + bump compat to 7
    + use a .manpages file for dh_installman
  * Switch to format "3.0 (quilt)".
  * Install the upstream README and TODO only for libepub0.
  * Small copyright update.
  * Tweak descriptions a bit.
  * Activate the "as needed" linking.
  * Add a symbols file for libepub0:
    + based on the symbols of libepub 0.1.1
    + mark the internal symbols as optional
    + update taking the 0.2.0 version into account
  * Remove duplicate field "Section" in package libepub0.
  * Small update to the einfo.1 manpage:
    + remove the -n parameter, no more available
  * Add "DM-Upload-Allowed: yes" in control.
  * Bump Standards-Version to 3.9.1, no changes required.

 -- Pino Toscano <pino@kde.org>  Wed, 15 Sep 2010 22:14:33 +0200

ebook-tools (0.1.1-3) unstable; urgency=low

  * Change epub-utils suggests clit and zip into recommends convlit and zip.
    (Closes: #529852)
  * As debhelper is used, add ${misc:Depends} to the depends of the binary
    packages.
  * Change the section of ebook-tools-dbg to debug.
  * Remove lintian override for ebook-tools-dbg, no more needed now.
  * Bump Standards-Version to 3.8.1. No changes needed.

 -- Pino Toscano <pino@kde.org>  Fri, 22 May 2009 23:44:12 +0200

ebook-tools (0.1.1-2) unstable; urgency=low

  * add patch 01_lit2epub_bashisms.diff:
    + fixes bashisms in lit2epub (Closes: #486031)
    + taken from upstream r93
  * debian/rules:
    + add build-dependency on quilt
  * debian/einfo.1:
    + hypen and minus are different, so escape the minus char to get a minus
      in the man page

 -- Pino Toscano <pino@kde.org>  Sat, 14 Jun 2008 00:34:25 +0200

ebook-tools (0.1.1-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.8.0. No changes needed.
  * debian/control:
    + ebook-tools-dbg: remove dependency on libc6-dbg
  * debian/ebook-tools-dbg.lintian-overrides:
    + override the lintian warning about the "ebook-tools" package,
      as the real package that needs debug symbols is libepub0
  * debian/einfo.1:
  * debian/lit2epub.1:
  * debian/rules:
    + add manpages for einfo(1) and lit2epub(1)

 -- Pino Toscano <pino@kde.org>  Fri, 07 Jun 2008 22:00:47 +0200

ebook-tools (0.1.0-1) unstable; urgency=low

  * Initial release (Closes: #475513)

 -- Pino Toscano <pino@kde.org>  Mon, 19 May 2008 14:34:04 +0200