1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25
|
export LDLIBS += -Wl,--as-needed
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh $@ --sourcedir=source
override_dh_installchangelogs:
dh_installchangelogs README
override_dh_auto_install:
install -d $(CURDIR)/debian/tmp/usr/share/doc/ebumeter-doc
install -m 644 $(CURDIR)/doc/* \
$(CURDIR)/debian/tmp/usr/share/doc/ebumeter-doc/
install -d $(CURDIR)/debian/tmp/usr/share/applications
install -m 644 $(CURDIR)/debian/ebumeter.desktop \
$(CURDIR)/debian/tmp/usr/share/applications/
install -d $(CURDIR)/debian/tmp/usr/share/pixmaps/
install -m 644 $(CURDIR)/debian/ebumeter32x32.xpm \
$(CURDIR)/debian/tmp/usr/share/pixmaps/
dh_auto_install
|