1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48
|
DEB_BUILD_ARCH ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
export DEB_CFLAGS_MAINT_APPEND = -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
dh ${@} --with autoreconf
override_dh_autoreconf:
dh_autoreconf ./autogen.sh
override_dh_auto_configure:
dh_auto_configure -- \
--enable-gpg --enable-pam --enable-static --enable-tspi \
--disable-gui --disable-openssl --disable-pkcs11-helper \
--disable-pywrap \
CFLAGS="$(CFLAGS)"
override_dh_auto_install:
dh_auto_install
install -D -m 0644 debian/local/ecryptfs-utils.pam-auth-update debian/ecryptfs-utils/usr/share/pam-configs/ecryptfs-utils
install -D -m 0644 debian/local/ecryptfs-utils.kmod debian/ecryptfs-utils/lib/modules-load.d/ecryptfs.conf
rm -f debian/tmp/usr/lib/*/*.la
override_dh_fixperms:
dh_fixperms
chmod 4755 debian/ecryptfs-utils/sbin/mount.ecryptfs_private
override_dh_install:
dh_install --fail-missing
.PHONY: override_dh_autoreconf override_dh_auto_configure \
override_dh_auto_install override_dh_install \
override_dh_fixperms
|