1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79
|
From: Dejan Latinovic <Dejan.Latinovic@imgtec.com>
Date: Tue, 11 Mar 2014 18:16:39 +0100
Description: include "config.h" before including system headers
The following source files were modified to include "config.h" before
including system headers (due to changes in gnulib).
Debian-Bug:
@@ -15,6 +15,9 @@
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <stdlib.h>
#include <stdio.h>
#include <stdint.h>
@@ -15,6 +15,9 @@
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <stdint.h>
#include <stdlib.h>
#include <stdio.h>
@@ -15,6 +15,9 @@
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <unistd.h>
#include <stdlib.h>
#include <stdio.h>
@@ -17,6 +17,9 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
//#include <sys/time.h>
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <time.h>
#include <string.h>
#include <stdlib.h>
@@ -17,6 +17,9 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
//#include <sys/time.h>
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <time.h>
#include <string.h>
#include <stdlib.h>
@@ -16,6 +16,9 @@
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
//#include <sys/time.h>
+#if HAVE_CONFIG_H
+#include <config.h>
+#endif
#include <time.h>
#include <string.h>
#include <stdlib.h>
|