File: .travis.yml

package info (click to toggle)
efivar 34-1~bpo9%2B1
  • links: PTS, VCS
  • area: main
  • in suites: stretch-backports
  • size: 1,048 kB
  • sloc: ansic: 9,074; makefile: 217; asm: 31
file content (110 lines) | stat: -rw-r--r-- 3,597 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
sudo: required
language: c
install: true
script: make all

matrix:
  include:
    - compiler: gcc
      env:
        - COMPILER=gcc-4.9
        - CROSS_COMPILE=x86_64-linux-gnu-
      dist: xenial
      addons:
        apt:
          sources:
            - ubuntu-toolchain-r-test
          packages:
            - gcc-4.9
            - binutils
      before_install:
        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
        - sudo apt-get update -qq
        - sudo apt-get install gcc-4.9 binutils libpopt-dev pkg-config
        - test -n $CC && unset CC
    - compiler: gcc
      env:
        - COMPILER=gcc-5
        - CROSS_COMPILE=x86_64-linux-gnu-
      dist: xenial
      addons:
        apt:
          sources:
            - ubuntu-toolchain-r-test
          packages:
            - gcc-5
            - binutils
      before_install:
        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
        - sudo apt-get update -qq
        - sudo apt-get install gcc-5 binutils libpopt-dev pkg-config
        - test -n $CC && unset CC
    - compiler: gcc
      env:
        - COMPILER=gcc-6
        - CROSS_COMPILE=x86_64-linux-gnu-
      dist: xenial
      addons:
        apt:
          sources:
            - ubuntu-toolchain-r-test
          packages:
            - gcc-6
            - binutils
      before_install:
        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
        - sudo apt-get update -qq
        - sudo apt-get install gcc-6 binutils libpopt-dev pkg-config
        - test -n $CC && unset CC
#    - compiler: gcc
#      env:
#        - COMPILER=gcc-7
#        - CROSS_COMPILE=x86_64-linux-gnu-
#      dist: zesty
#      addons:
#        apt:
#          sources:
#            - ubuntu-toolchain-r-test
#          packages:
#            - gcc-7
#            - binutils
#      before_install:
#        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
#        - sudo apt-get update -qq
#        - sudo apt-get install gcc-7 binutils libpopt-dev pkg-config
#        - test -n $CC && unset CC
#    - compiler: clang
#      env: COMPILER=clang-3.6
#      before_install:
#        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
#        - sudo add-apt-repository ppa:jonathonf/llvm -y
#        - sudo apt-get update -qq
#        - sudo apt-get install clang-3.6 binutils libpopt-dev pkg-config
#    - compiler: clang
#      env: COMPILER=clang-3.7
#      before_install:
#        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
#        - sudo add-apt-repository ppa:jonathonf/llvm -y
#        - sudo apt-get update -qq
#        - sudo apt-get install clang-3.7 binutils libpopt-dev pkg-config
#    - compiler: clang
#      env: COMPILER=clang-3.8
#      before_install:
#        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
#        - sudo add-apt-repository ppa:jonathonf/llvm -y
#        - sudo apt-get update -qq
#        - sudo apt-get install clang-3.8 binutils libpopt-dev pkg-config
#    - compiler: clang
#      env: COMPILER=clang-3.9
#      before_install:
#        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
#        - sudo add-apt-repository ppa:jonathonf/llvm -y
#        - sudo apt-get update -qq
#        - sudo apt-get install clang-3.9 binutils libpopt-dev pkg-config
#    - compiler: clang
#      env: COMPILER=clang-4.0
#      before_install:
#        - sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y
#        - sudo add-apt-repository ppa:jonathonf/llvm -y
#        - sudo apt-get update -qq
#        - sudo apt-get install clang-4.0 binutils libpopt-dev pkg-config