File: rules

package info (click to toggle)
el-api 3.0.0-3
  • links: PTS, VCS
  • area: main
  • in suites: bookworm, bullseye, sid
  • size: 528 kB
  • sloc: java: 2,320; xml: 222; makefile: 7
file content (12 lines) | stat: -rwxr-xr-x 436 bytes parent folder | download | duplicates (2)
1
2
3
4
5
6
7
8
9
10
11
12
#!/usr/bin/make -f

%:
	dh $@

override_dh_auto_install:
	# Install the old javax.el:javax.el-api:3.0 artifacts
	mh_installpom -plibel-api-java --no-parent --set-version=3.0 --rules=debian/maven.rules.compat pom.xml
	rm -Rf debian/libel-api-java/usr/share/maven-repo/javax/el/javax.el-api/debian/
	dh_link -plibel-api-java /usr/share/java/el-api.jar usr/share/maven-repo/javax/el/javax.el-api/3.0/javax.el-api-3.0.jar

	dh_auto_install