File: changelog

package info (click to toggle)
elasticsearch-curator 5.8.1-1
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 1,920 kB
  • sloc: python: 17,468; sh: 464; makefile: 160
file content (146 lines) | stat: -rw-r--r-- 4,954 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
elasticsearch-curator (5.8.1-1) unstable; urgency=medium

  [ Emmanuel Arias ]
  * Team upload
  * New upstream version 5.8.1
  * Remove Python 2 support (Closes: #936473)
  * Bump debhelper-compat to 12
  * Bump standard version to 4.4.1
  * Update Build Depends
  * Fix override_dh_auto_clean on d/rules
  * Add me to d/copyright
  * d/rules: Remove unused targets
    - Remove override_dh_installchangelogs, it's not generated
    - Remove empty override_dh_auto_test
  * d/tests: Remove existing tests. They fail because elasticsearch binary
    was removed.
    - Add debian/tests/pkg-python/import-name to override the import name.
  * Add patch to skip tests that fail.
  * d/control: add autopkgtest-pkg-python

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Use https protocol in Format field
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field
  * Convert git repository from git-dpm to gbp layout
  * Use 'python3 -m sphinx' instead of sphinx-build for building docs
  * Use debhelper-compat instead of debian/compat.

 -- Emmanuel Arias <eamanu@yaerobi.com>  Fri, 15 Nov 2019 23:06:35 -0300

elasticsearch-curator (5.2.0-1) unstable; urgency=medium

  [ Aggelos Avgerinos ]
  * Bump standards version; no changes needed
  * Bump compat and debhelper versions; no changes needed
  * d/control: Bump python-elasticsearch dependency version

  [ Apollon Oikonomopoulos ]
  * New upstream version. (Closes: #865288)
  * Add Aggelos to Uploaders.
  * B-D on python3-sphinx.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Tue, 17 Oct 2017 10:57:54 +0300

elasticsearch-curator (4.2.5-1) unstable; urgency=medium

  * New upstream release

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Mon, 02 Jan 2017 14:42:36 +0200

elasticsearch-curator (4.2.4-1) unstable; urgency=medium

  * New upstream release
  * Build and ship asciidoc documentation as reference.txt.gz
  * B-D on python{3,}-voluptuous and python{3,}-yaml; required for building
    the sphinx documentation.
  * Add curator_cli(1) manpage
  * Update the curator(1) and es_repo_mgr(1) manpages

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Fri, 16 Dec 2016 14:50:51 +0200

elasticsearch-curator (4.1.0-1) unstable; urgency=medium

  * New upstream release.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Sat, 10 Sep 2016 12:08:02 +0300

elasticsearch-curator (4.0.6-1) unstable; urgency=medium

  * New upstream release
  * Set elasticsearch-curator's Section to admin (Closes: #832206)

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Wed, 07 Sep 2016 15:30:02 +0300

elasticsearch-curator (4.0.1-2) unstable; urgency=medium

  * Restrict intersphinx from downloading object inventory data (Closes:
    #830550):
    + sphinx: use local inventory references for intersphinx
    + B-D on python3-doc and python-elasticsearch-doc

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Fri, 22 Jul 2016 23:51:01 +0300

elasticsearch-curator (4.0.1-1) unstable; urgency=medium

  * New upstream release.
  * The 'DebConf16' upload.
  * Bump Standards to 3.9.8; no changes needed.
  * d/watch: uversionmangle upstream's alphas and betas.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Wed, 29 Jun 2016 21:02:32 +0200

elasticsearch-curator (3.5.1-1) unstable; urgency=medium

  * New upstream release.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Mon, 21 Mar 2016 22:58:33 +0200

elasticsearch-curator (3.4.1-1) unstable; urgency=medium

  * New upstream release.
  * Bump standards to 3.9.7; no changes needed.
  * d/control: Use HTTPS in Vcs-Git.
  * d/copyright: extend to 2016.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Fri, 12 Feb 2016 14:32:53 +0200

elasticsearch-curator (3.4.0-1) unstable; urgency=medium

  * New upstream release
    + Elasticsearch 2.0 support
  * Add B-D on python{,3}-click (Closes: #802962)
  * Add DEP-8 tests
  * d/watch: mangle upstream RC versions

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Wed, 04 Nov 2015 14:29:48 +0200

elasticsearch-curator (3.3.0-1) unstable; urgency=medium

  * New upstream release.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Fri, 23 Oct 2015 15:58:59 +0300

elasticsearch-curator (3.2.3-1) unstable; urgency=medium

  * New upstream release.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Mon, 20 Jul 2015 10:28:20 +0300

elasticsearch-curator (3.2.0-1) unstable; urgency=medium

  * New upstream release
    + Mention breaking changes in debian/NEWS
  * Depend on python-pkg-resources
  * Refresh setup.py-read-README-utf-8 patch

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Fri, 10 Jul 2015 14:10:21 +0300

elasticsearch-curator (2.1.2-1) unstable; urgency=low

  * Initial release (closes: #776791)
  * Disable testuite; upstream runs integration tests against a local ES
    instance, erasing existing data.

 -- Apollon Oikonomopoulos <apoikos@debian.org>  Mon, 02 Feb 2015 13:53:33 +0200