File: .travis.yml

package info (click to toggle)
elpy 1.34.0-2
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, sid
  • size: 2,512 kB
  • sloc: lisp: 11,667; python: 3,012; makefile: 167; sh: 60
file content (79 lines) | stat: -rw-r--r-- 2,079 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
language: python

sudo: false

# needed for emacs26 to work
dist: trusty

python:
  - 2.7
  - 3.5
  - 3.6

# While python3.7 is not supported by default dist...
matrix:
    include:
      # - sudo: required
      #   dist: xenial
      #   python: 3.7
      #   env: EVM_EMACS=emacs-24.4-travis
      - sudo: required
        dist: xenial
        python: 3.7
        env: EVM_EMACS=emacs-24.5-travis
      - sudo: required
        dist: xenial
        python: 3.7
        env: EVM_EMACS=emacs-25.1-travis
      - sudo: required
        dist: xenial
        python: 3.7
        env: EVM_EMACS=emacs-25.2-travis
      - sudo: required
        dist: xenial
        python: 3.7
        env: EVM_EMACS=emacs-25.3-travis
      # - sudo: required
      #   dist: xenial
      #   python: 3.7
      #   env: EVM_EMACS=emacs-26.1-travis
      # - sudo: required
      #   dist: xenial
      #   python: 3.7
      #   env: EVM_EMACS=emacs-26.2-travis
      # - sudo: required
      #   dist: xenial
      #   python: 3.7
      #   env: EVM_EMACS=emacs-26.3-travis

env:
  # - EVM_EMACS=emacs-24.4-travis
  - EVM_EMACS=emacs-24.5-travis
  - EVM_EMACS=emacs-25.1-travis
  - EVM_EMACS=emacs-25.2-travis
  - EVM_EMACS=emacs-25.3-travis
  - EVM_EMACS=emacs-26.1-travis
  - EVM_EMACS=emacs-26.2-travis
  - EVM_EMACS=emacs-26.3-travis
before_install:
  - source ./travis-evm-cask.sh
  - evm install $EVM_EMACS --use --skip
  - cask --verbose        # verbose only needed because of cask bug
install:
  - pip install -r requirements.txt --upgrade
  - pip install -r requirements-rpc.txt --upgrade
  - pip install -r requirements-dev.txt --upgrade
  - if [[ "$TRAVIS_PYTHON_VERSION" > 3.5 ]] ; then
      pip install -r requirements-rpc3.6.txt --upgrade ;
    fi
  - if [[ "$TRAVIS_PYTHON_VERSION" < 3 ]] ; then
      pip install -r requirements-dev2.txt --upgrade ;
    fi
  - pip install coveralls
  - virtualenv ~/.virtualenvs/elpy-test-venv
script:
  - nosetests
  - PYTHONPATH="`pwd`" cask exec ert-runner --reporter ert+duration
after_success:
  - coverage run -m nose.__main__
  - coveralls