1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50
|
The Debian packaging of emacs-noflet is maintained in git, using the
merging workflow described in dgit-maint-merge(7). There isn't a
patch queue that can be represented as a quilt series.
A detailed breakdown of the changes is available from their canonical
representation - git commits in the packaging repository. For
example, to see the changes made by the Debian maintainer in the first
upload of upstream version 1.2.3, you could use:
% git clone https://git.dgit.debian.org/emacs-noflet
% cd emacs-noflet
% git log --oneline 1.2.3..debian/1.2.3-1 -- . ':!debian'
(If you have dgit, use `dgit clone emacs-noflet`, rather than plain
`git clone`.)
A single combined diff, containing all the changes, follows.
--- /dev/null
+++ emacs-noflet-0.0.15/.gitignore
@@ -0,0 +1 @@
+debian/elpa-noflet
--- emacs-noflet-0.0.15.orig/noflet.el
+++ emacs-noflet-0.0.15/noflet.el
@@ -6,6 +6,7 @@
;; Keywords: lisp
;; Version: 0.0.15
;; Url: https://github.com/nicferrier/emacs-noflet
+;; Package-Requires: ((cl-lib "0.4") (dash "2.10.0"))
;; This program is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
@@ -28,7 +29,8 @@
;;; Code:
-(eval-when-compile (require 'cl))
+(require 'dash)
+(eval-when-compile (require 'cl-lib))
(if (version< emacs-version "24.4.1")
(load-library "cl-indent")
(require 'cl-indent))
@@ -155,7 +157,7 @@ maintainers refuse to add the correct in
(indent noflet-indent-func))
`(cl-flet ,bindings ,@body))
-(defmacro* letn (tag bindings &rest body)
+(cl-defmacro letn (tag bindings &rest body)
(declare (debug (sexp sexp &rest form))
(indent 2))
`(cl-labels ((,tag ,(-map 'car bindings) ,@body))
|