File: changelog

package info (click to toggle)
emboss-explorer 2.2.0-10
  • links: PTS, VCS
  • area: main
  • in suites: bullseye, buster, sid
  • size: 352 kB
  • sloc: perl: 1,765; sh: 92; makefile: 12
file content (185 lines) | stat: -rw-r--r-- 7,867 bytes parent folder | download
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
emboss-explorer (2.2.0-10) unstable; urgency=medium

  * Team upload.
  * debhelper 11
  * Point Vcs fields to salsa.debian.org
  * Standards-Version: 4.2.1
  * Depends: sensible-utils

 -- Andreas Tille <tille@debian.org>  Tue, 09 Oct 2018 18:00:50 +0200

emboss-explorer (2.2.0-9) unstable; urgency=medium

  * Team upload
  * Moved packaging to Git
  * cme fix dpkg-control
  * Standards-Version: 4.1.0 (no changes needed)
  * debhelper 10
  * Fix symlink
    Closes: #861038
  * Remove debian/menu since there is a desktop file

 -- Andreas Tille <tille@debian.org>  Tue, 26 Sep 2017 14:48:02 +0200

emboss-explorer (2.2.0-8) unstable; urgency=low

  [ David Paleino ]
  * Removed myself from Uploaders

  [ Charles Plessy ]
  * Converted patches from dpatch to quilt format.
  * Converted the source package to dpkg source format 3.0 (quilt).
  * Added a DEP 3 header to the patches.
  * Removed debian/emboss-explorer.preinst, useless after Lenny.
  * Conforms with Policy 3.9.4 (debian/control, no other changes needed).
  * Use canonical VCS URLs in debian/control. 
  * Updated debian/copyright to latest machine-readable format.
  * Switch to Debhelpers compatibility level 9 (debian/compat, debian/control).
  * Convert to Debhelper's tiny mode (debian/rules, debian/docs).
  * Removed obsolete DM-Upload-Allowed field.
  * Normalised debian/control with config-model-edit.
  * Removed restriction on EMBOSS version, satisified even in oldstable.
  * Verbose build logs (debian/rules).
  * Added Debhelper’s misc:Depends substitution variable.
  * Use dh_apache2 (Closes: #669738).
    - Build-depend on apache2-dev for dh_apache2.
    - Invoke dh_apache2 through dh.
    - Updated Apache configuration file for 2.4.
    - Updated debian/emboss-explorer.links for new name of configuration file.
    - Override ‘apache2-deprecated-auth-config’ warning (would conflict
      with another file).
    - Delete obsolete postinst and postrm files.
    - Recommend apache2 or httpd through misc:Recommends.
  * Added keywords to the desktop entry.
  * Correct path for moving ACD.pm and its manual page.
  * Apply patch from upstream tracker to use emboss-explorer with EMBOSS 6.4
    (Closes: #722982 LP:#1083426).
  * Correct the alias to the EMBOSS documentation.  Closes: #485735.

 -- Charles Plessy <plessy@debian.org>  Sun, 15 Sep 2013 13:50:12 +0900

emboss-explorer (2.2.0-7) unstable; urgency=low

  * debian/emboss-explorer.postinst: reloads apache.
  * debian/menu, debian/emboss-explorer.desktop,
    debian/rules, debian/emboss-explorer.install: adding menu entries starting
    a browser on http://localhost/emboss-explorer.
  * debian/README.source, debian/control: added instructions for patching
    and updated Standards-Version.
  * debian/compat, debian/control: using Debhelper 7.

 -- Charles Plessy <plessy@debian.org>  Sun, 07 Dec 2008 20:21:35 +0900

emboss-explorer (2.2.0-6) unstable; urgency=low

  [ Charles Plessy ]
  * Relicensed the packaging work to "Same as EMBOSS explorer".
  * debian/patches:
    - Documented 01-fix_examples.dpatch.
    - Documented and forwarded 02-fix_Conf.pm.dpatch and
      05-build-manpages.dpatch.
    - Suppressed 04-fix_install.dpatch. Its role is taken by debian/rules and
      debian/index.html.
  * debian/rules:
    - refreshed using dh-make-perl version 0.45;
    - tests disable because of upstream bug 1994385;
    - sets the owner of the emboss output directory as `www-data';
    - touches the makefile to avoid timestamp artefacts due to the patching of
      Makefile.PL (Thanks to Damyan and Gregor for the hint!).
  * Package made compatible with FHS by not using /var/www.
    - HTML files moved to `/usr/emboss-explorer/html'.
    - Cascade stylesheets moved to `/etc/emboss-explorer/style'
      (they are intended to be modifiable).
    - Temporary files moved to `/var/lib/emboss-explorer'
    - /etc/emboss-explorer/apache.conf allows apache2 to access the files in
      the /user/share/emboss-explorer directory, as well as the EMBOSS
      documentation in /usr/share/doc/emboss-explorer/ (Closes: #485735).
  * debian/emboss-explorer.manpages, debian/acdcheck.1*, debian/mkstatic.1*
    suppressed to use Upstream's manpages.
  * debian/emboss-explorer.postrm removes the temporary files when the package
    is purged.
  * debian/emboss-explorer.preinst moves the emboss-explorer.conf in its new
    place.

  [ David Paleino ]
  * debian/control:
    - dropped dependency on libcgi-perl (Closes: #485009)
    - updated Charles' email :)
  * debian/copyright updated

 -- Charles Plessy <plessy@debian.org>  Sat, 05 Jul 2008 16:29:07 +0900

emboss-explorer (2.2.0-5) unstable; urgency=low

  * debian/control:
    - Allowed upload by Debian maintainers.
    - Changed Maintainer to Debian-Med Packaging Team.
    - Changed VCS to Debian-Med's subversion repository.
    - Checked conformance with Policy 3.7.3 (no changes needed).
  * debian/copyright: converted to machine-readable format.

 -- Charles Plessy <charles-debian-nospam@plessy.org>  Wed, 05 Mar 2008 20:14:55 +0900

emboss-explorer (2.2.0-4) unstable; urgency=low

  [ David Paleino ]
  * debian/do_cleanup.sh removed -- its contents are now directly
    put in the crontab file. (Closes: #435991)

  [ Charles Plessy ]
  * Gave ownersip of /var/www/emboss-explorer/output to www-data in
    debian/rules, removed the postinst script which was doing this before.
  * Added a reference to the stylesheets in the xml sources of the
    manpages, to simplify their use with xsltproc.
  * Generated the manpages offline, and dropped the build-dependency on
    xsltproc, docbook-xml and docbook-xsl.
  * Using debian/emboss-explorer instead of debian/tmp as build directory.
  * Removed the XS- prefix in front of the Vcs-* fields on debian/control.
  * Removed instructions to handle a deleted script, do_cleanup.sh

 -- Charles Plessy <charles-debian-nospam@plessy.org>  Mon, 05 Nov 2007 10:38:07 +0900

emboss-explorer (2.2.0-3) unstable; urgency=low

  [ David Paleino ]
  * debian/do_cleanup.sh added to handle crontab (Closes: #435991)
  * debian/emboss-explorer.cron.d and debian/emboss-explorer.install
    edited to reflect the changes
  * debian/emboss-explorer.dirs edited to add /usr/share/emboss-explorer/
  * debian/control - removing unused ${misc:Depends}

  [ Charles Plessy ]
  * Changed section of libemboss-acd-perl from science to perl.

 -- David Paleino <d.paleino@gmail.com>  Sun, 07 Oct 2007 13:08:54 +0200

emboss-explorer (2.2.0-2) unstable; urgency=low

  * Migration from /var/www/emboss to /var/www/emboss-explorer was
    incomplete. Correcting this.
  * Fixed double-building of the manpages.
  * Added myself to the uploaders.
  * Swiched to apache2 as the default webserver.
  * emboss-explorer.conf now defaults to /usr/lib/emboss, which is the
    only place where the emboss binaries are guaranteed to keep their
    original name (therefore depending on emboss >= 5.0.0).
  * Provides emboss-explorer.conf through a file, not a patch. Modifying
    ./install so that it does not manipulate emboss-explorer.conf anymore
    so that there is a single entry point to change the default
    configuration.
  * Added a configure rule so that the clean rule can always run make clean.
  * Using include /usr/share/dpatch/dpatch.make.
  * Added libcgi-perl in the Depends: field of emboss-explorer.
  * Added libparse-recdescent-perl in the Depends: field of
    libemboss-acd-perl (Thanks to Anthony Boureux).
  * Moved dpatch from Build-depends-indep to Build-depends, because it is
    needed for debian/rules clean.

 -- Charles Plessy <charles-debian-nospam@plessy.org>  Sun, 15 Jul 2007 16:08:24 +0900

emboss-explorer (2.2.0-1) experimental; urgency=low

  * Initial release (Closes: #423548)

 -- David Paleino <d.paleino@gmail.com>  Sat, 12 May 2007 17:52:59 +0200